HydrogenBomb May 24, 2013 @ 11:20pm
Serious Sam 3 Light Flickering
Never really had an issue with Serious Sam 3, until Nvidia came out with their new drivers, 320.18. Ever since, the lighting on the sand, out in wide open desert areas, would flicker like a strobe light. This would give me a headache and I am probably wondering if I should downgrade to Nvidias 314.00 drivers? Anyone else having this issue, or ever had this kind of issue?


05/25/2013
For Nvidia Drivers, revert back to 314.22. Flickerings will stop, and everything will be back to normal.
Last edited by HydrogenBomb; Jun 25, 2013 @ 4:43pm
Showing 1-15 of 67 comments
< >
Cunin May 25, 2013 @ 7:53am 
Well I'm on an AMD card and noticed the same yesterday, mostly when there was lots going on, and I noticed it first time at the first fight against the ship in coop. I was busy somewhere else while the other people were fighting it, and it started flickering.
I could get some screenshots of it and i'll upload them right now and post them here.

Actually, I'm not sure if I turned off multithreading, so that might be the cause of it. I'll check and report back.

EDIT:
Yes it was still on. Do you happen to have ti enabled too? It's called ren_bMultiThreadedRendering, and you can just put that in the console and press enter to see its state.
I'm not sure if that caused it anyway, I'll check again later and see if with it disabled I still get it.

Croteam: if you still want the screenshots I can upload them.
Last edited by Cunin; May 25, 2013 @ 7:58am
HydrogenBomb May 25, 2013 @ 9:11am 
I fixed it. I just had to downgrade the drivers.
The-Guardian May 25, 2013 @ 9:46am 
I have not got this issue with the latest nvidia driver. Maybe its a driver issue since u downgraded and it is working well with the 314
Rasta Pedobear (your dad) May 25, 2013 @ 10:24am 
:) Looks like 320.18 is bad driver for both OS, windows also.
Last edited by Rasta Pedobear (your dad); May 25, 2013 @ 10:24am
HydrogenBomb May 25, 2013 @ 11:51am 
I'll upgrade back to 320.18 again. I just want to downgrade so I can play the game without any weird problems :P
Cunin May 26, 2013 @ 8:33am 
Well it keeps happening even after disabling multithreading for me, and I'm on AMD. It would be pretty weird if both brands has the same driver bug lol.

Anyway I was able to take what happens on screenshots, seems like it happens always in the section right before the first ship fight, while in the rest of the level it doesn't, and it doesn't happen in the ship fight area. It also happens in later levels, but I didn't see it in earlier ones.

It only flicker when looking around or moving, but if you stand still and not move the mouse, it doesn't (though the lighting bug keeps standing there):
http://oi42.tinypic.com/e0jzfp.jpg
http://oi41.tinypic.com/2d0md7n.jpg
http://oi40.tinypic.com/90raqa.jpg

Seems like that guy has a similar problem lol
ARMY guy May 26, 2013 @ 6:10pm 
I also have this issue on all 320.xx drivers, running SLI 670 4gbs. Also does it when SLI is disabled.
HydrogenBomb May 26, 2013 @ 6:55pm 
I have one gtx 670. Idk about SLI, but all my games work fine now since redownloaded 314.22.
DEN [CT]  [developer] May 27, 2013 @ 4:31am 
Does this issue happen on all quality options?
Cunin May 27, 2013 @ 6:57am 
I'm not sure, I play with default detected settings.
HydrogenBomb May 27, 2013 @ 8:01am 
I honestly don't know about the all quality options since I like to put mine all the way up, but I'm sure it'll still happen just because of that particular version to the nvidia driver. So if you have a gtx 670 or above, stay with 314.22 unless there is a fix.


I can't figure out SLI, since I don't have it, and I'm no expert.
Last edited by HydrogenBomb; May 29, 2013 @ 11:29am
Szoreny Klepko May 29, 2013 @ 7:51am 
GTX 680 here, having the issue as well on 320.00 drivers. I also get a weird crescent moon shaped shader patch following sam around occasionally., and see the same effect in triangular patches near the corners of some walls.

http://steamcommunity.com/sharedfiles/filedetails/?id=148775312
Last edited by Szoreny Klepko; May 29, 2013 @ 10:45am
DEN [CT]  [developer] May 29, 2013 @ 8:38am 
Can you try this cvar, please:
sha_iParallaxMappingMethod=0
and then
shaReloadShaders()

Does this help?
HydrogenBomb May 29, 2013 @ 11:30am 
Try drivers 314.22 again. I don't bother with 320.18.
Originally posted by Krassar_Szoreny:
GTX 680 here, having the issue as well on 320.00 drivers. I also get a weird crescent moon shaped shader patch following sam around occasionally., and see the same effect in triangular patches near the corners of some walls.

http://steamcommunity.com/sharedfiles/filedetails/?id=148775312
Szoreny Klepko May 29, 2013 @ 9:43pm 
Originally posted by DEN CT:
Can you try this cvar, please:
sha_iParallaxMappingMethod=0
and then
shaReloadShaders()

Does this help?

DEN, those CVARS do stop the lights and shadows from flickering on my machine, so it does seem parrallax related.

Flipping parrallax back on and reloading shaders brought the flickering right back.



Last edited by Szoreny Klepko; May 29, 2013 @ 9:43pm
Showing 1-15 of 67 comments
< >
Per page: 15 30 50