$torM!@Linux! Mar 24, 2013 @ 5:43am
SS3 fails to run after loading libXrandr.so.2
Has anyone been able to get Serious Sam 3 to run using Xinerama on an nvidia setup? It's my understanding from googling that this is not possible, and try as I might I have been unable to disable the option using nvidia-settings, nvidia-xconfig or manually editing xorg.conf.

After starting the game, a black screen appears, then just before where there should be information about the display the user is using the game dies. Here's the full log and my xorg.conf. I'm running 64-bit arch linux with an nvidia 9800GT card.

http://www.jpirie.com/files/Sam3.log
http://www.jpirie.com/files/xorg.conf

If I physically unplug a monitor, and attempt to start the game, the same problem exists.

When starting nvidia-settings I see this dumped to the output:

Xlib: extension "RANDR" missing on display ":0.0".

I thought I'd add that in case it was relevant, but it's also my understanding that fixing that problem is not currently possible (this problem 'apparently' only occurs when using Xinerama, though as I have not be able to disable it, I cannot confirm this).

Any help most welcome, thanks!
Last edited by $torM!@Linux!; Mar 24, 2013 @ 5:45am
Showing 1-2 of 2 comments
< >
keks  [developer] Mar 25, 2013 @ 2:40am 
Your xorg.conf header comment says you're using 304 drivers. You should upgrade to (at least) 310, otherwise the game won't work well.

For now, xinerama is not supported on linux. If you create a new xorg.conf using nvidia-xconfig and set up muliple monitors with twinview (which in recent nvidia drivers actually uses xrandr) the game should work.
Last edited by keks; Mar 25, 2013 @ 2:45am
$torM!@Linux! Mar 29, 2013 @ 2:23pm 
I am indeed using the 304 drivers, alas if I upgrade to 310 any half life 2 engine based games will not run at all as no opengl version is detected, this must be a bug in the package of the 310 drivers in Arch I suspect. It's annoying indeed, I've filled a bug meanwhile.

Indeed Xinerama does not seem to be supported but I cannot find any way of disabling it, using either the methods you described or just writing a basic xorg.conf fresh specifying Xinerama as disabled. If I set it to specifically use twinview, in xorg.conf or via nvidia-settings and write an xorg.conf from there, it will be ignored and it will just enable Xinerama anyway. Perhaps there is something in the system that requires it and overrides the configuration. Hrm.
Showing 1-2 of 2 comments
< >
Per page: 15 30 50
Date Posted: Mar 24, 2013 @ 5:43am
Posts: 2