Serious Sam 3: BFE
Shindi Dec 16, 2013 @ 2:00pm
Game won't start
So I go to launch it andit doesn't even open. Like, it does the whole "Steam first time setup" thing, then not even a popup and the game closes. Any ideas?
< >
Showing 1-13 of 13 comments
AlenL  [developer] Dec 16, 2013 @ 2:22pm 
Have you tried doing Verify Game Cache?
Edit: Solais, I don't think it's got something to do with DirectX. If it was that, it would say "Fatal Error: Cannot set display mode."
Last edited by AlenL; Dec 16, 2013 @ 2:22pm
Shindi Dec 16, 2013 @ 2:45pm 
I did try the cache thing and nothing came up, so im reinstalling it to see if it works
AlenL  [developer] Dec 16, 2013 @ 3:41pm 
If none of that helps, then see if you have some AV program installed. Disabling it before doing a verify can make a difference. Also, try running the moddable version. For some people sometimes one exe installs well when the other doesn't.
✪EggHunt3r☢ Dec 16, 2013 @ 6:50pm 
i already reinstall the game an nothing happends is it compatible with maverics????
Shindi Dec 17, 2013 @ 9:59am 
i started modable version,then normal version and it worked fine. Maybe that'kk help you, egghunter.
✪EggHunt3r☢ Dec 17, 2013 @ 1:51pm 
didint eaven start D: idk what to do
Shindi Dec 17, 2013 @ 3:55pm 
Hmm.. try restarting steam. if that doesnt work, try restarting your pc, if not try reinstalling the game then do a verify. then try starting the modable version, if that works, try starting the normal version. if not, idk.
Cupcake Freedom Dec 17, 2013 @ 7:29pm 
It downloads and I think I saw it install but it just boots to a black screen. Tried modable version and the vanilla, no dice. I've got an insane backlog and I grabbed this on a Humble Bundle so I'll just stash this for a rainy day

I've got all my drivrz tho
AMD FX QuadCore 3.6
AMD Radeon HD 6700
Shindi Dec 17, 2013 @ 7:33pm 
Hmm couldnt tell you if it has anything to do with those.. i use NVidia.
AlenL  [developer] Dec 17, 2013 @ 8:54pm 
Cupcake Freedom, please post your log file. Without more data I would suspect that this is the case of Bulldozer CPU, which needs a BIOS update. It's in the FAQ.
Uncle Moreels Dec 18, 2013 @ 11:27pm 
Also try updating your Nvidia drivers and perhaps check if there is any software still running. Software that uses realtime scanning like McAfee prevents from booting the game.
Cupcake Freedom Dec 20, 2013 @ 6:21pm 
I just hadn't run Windows update in a while. Works great now
McAfee is a bloated mess I dont use that garbage

Sorry & Thank You! Happy Holidays
< >
Showing 1-13 of 13 comments
Per page: 15 30 50

Date Posted: Dec 16, 2013 @ 2:00pm
Posts: 13