Super Meat Boy > Общи дискусии > Подробности за темата
MaksWell42 26 ноември 2012 в 2:01след.
Mac hates PS3 controller.
Few things have frustrated me as much in my life as trying to get my ps3 controller to work with my Mac for games like Super Meat Boy and Portals 1 & 2. Still no luck as of posting, very little hope left for the project.
Показване на 1-8 от 8 коментара
< >
hotmailcompany52 28 ноември 2012 в 8:48сут. 
More info would be nice so we caould isloate the problem.
Gankdomo 29 ноември 2012 в 5:32след. 
I had your problem and downloaded "GamePad Companion" from the app store for like $8. It is absolutely worth it. I use my PS3 controller for Super Meat Boy and The Binding of Isaac. It works perfectly. If you need any more help, let me know.
Duente Zaibatsu 30 ноември 2012 в 9:23сут. 
Also, even Mac hates Mac, so, thats your problem right there.
Blackbluue~The Blue Dragon 29 август 2013 в 2:31сут. 
ikd if this is your problem, but my ps3 controller is recognized by the game. the buttons are just mapped to the wrong places. same thing happens in a few other of my steam games. it would be ok, but since i cant change controls in-game there isnt much i can do about it.
anomaly 29 август 2013 в 9:34сут. 
Try changing the key bindings in buttonmap.cfg located in ~/Library/Application Support/Steam/SteamApps/common/Super Meat Boy/SuperMeatBoy.app/Contents/MacOS. Open it with TextEdit.
Blackbluue~The Blue Dragon 29 август 2013 в 10:48сут. 
greasy, i found the file but idk which input corresponds to which button on the game pad. i woul assume '1' is L3 since it jumps whenever i press it, but idk about anything else
anomaly 30 август 2013 в 6:35сут. 
Първоначално публикувано от Blackbluue~the Death Scythe:
greasy, i found the file but idk which input corresponds to which button on the game pad. i woul assume '1' is L3 since it jumps whenever i press it, but idk about anything else

Първоначално публикувано от jay:
[...]

open the file with text editor and change the buttons under gamepad to:

jump="10";
special="9";

now R1 is jump & L1 is special, which is a little odd, as according to gamepad companion button 10 should be R2 and 9 should be L2. But it works, so what the hell...

The problem is that this only works for the first level you play. Meaning as soon as you beat a level, only R1 works as it should. Any ideas why this might be?

Taken from http://steamcommunity.com/app/40800/discussions/0/864948938198159711/

Try using these settings. Unfortunately, as he says, they may reset every level.
anomaly 30 август 2013 в 6:41сут. 
Показване на 1-8 от 8 коментара
< >
На страница: 15 30 50
Дата на публикуване: 26 ноември 2012 в 2:01след.
Публикации: 8