Super Meat Boy > กระดานสนทนาทั่วไป > รายละเอียดกระทู้
Wolf 28 ส.ค. 2013 @ 1:59pm
Mac OS X gamepad issues!
I am using a Wireless Xbox 360 controller with a USB adapter. I have installed the software recomended for Mac from this link:

When in game the controller doesn't work properlly. The A button is actually down on the D-pad. Jump is left on the D-pad and there is no movement controlls at all. Is there any way to fix this?
กำลังแสดง 1-8 จาก 8 ความเห็น
< >
Smoke Monster 29 ส.ค. 2013 @ 9:57am 
Try changing the key bindings in buttonmap.cfg located in ~/Library/Application Support/Steam/SteamApps/common/Super Meat Boy/ Open it with TextEdit.
Wolf 29 ส.ค. 2013 @ 1:37pm 
it says:



โพสต์ดั้งเดิมโดย greasy grandma:
Try changing the key bindings in buttonmap.cfg located in ~/Library/Application Support/Steam/SteamApps/common/Super Meat Boy/ Open it with TextEdit.
Wolf 29 ส.ค. 2013 @ 1:39pm 
I will try changing Jump to 0 instead of 1
Wolf 29 ส.ค. 2013 @ 1:50pm 
hmmm I am still getting the same issues. It hasnt helped. I have tried changing the keybindings and I have done a fresh reinstall of the game too...
Smoke Monster 30 ส.ค. 2013 @ 6:31am 
โพสต์ดั้งเดิมโดย jay:
So close to this working without any controller mapping software! I know this is an old post but I figured i'd put it up just incase anyone can figure out the last part?

for SMB with PS3 controller on a mac go to:

/Users/{YOUR_USERNAME}/Library/Application\ Support/Steam/SteamApps/common/super\ meat\ boy/

open the file with text editor and change the buttons under gamepad to:


now R1 is jump & L1 is special, which is a little odd, as according to gamepad companion button 10 should be R2 and 9 should be L2. But it works, so what the hell...

The problem is that this only works for the first level you play. Meaning as soon as you beat a level, only R1 works as it should. Any ideas why this might be?

Taken from

Try using these settings. Unfortunately, as he says, they may reset every level.
Smoke Monster 30 ส.ค. 2013 @ 6:37am 
If that doesn't work, and you've already tried a bunch of other combinations, perhaps try different software. Other than that, I'm not sure what to do. Development on this game has been pretty sloppy.
Wolf 30 ส.ค. 2013 @ 8:11am 
I have currently got it working by setting the Config file to 99 with both so non of the controls interact with the mapped ones that I have set on Joymapper.

What I had to do was set the trigger button to + instead of the - value. For some reason the default scan set it so that it was toggled on until pressed, which would turn it off. So making it a + fixed the issue.

But allas still no way to get native support. The developtment for this game was poor past the XBLA version. You shouldnt put the game on Mac if it doesn't work and you have no intention on fixing it.
ได้รับการแก้ไขครั้งสุดท้ายโดย Wolf; 30 ส.ค. 2013 @ 8:12am
JAMZU98 23 ม.ค. 2014 @ 9:19am 
If you have problems with your controllers on mac check this out:
กำลังแสดง 1-8 จาก 8 ความเห็น
< >
ต่อหน้า: 15 30 50