Super Meat Boy > Obecné diskuze > Detaily tématu
Milkaholic 28. srp. 2013 v 1.59 odp.
Mac OS X gamepad issues!
I am using a Wireless Xbox 360 controller with a USB adapter. I have installed the software recomended for Mac from this link:

http://tattiebogle.net/index.php/ProjectRoot/Xbox360Controller/OsxDriver

When in game the controller doesn't work properlly. The A button is actually down on the D-pad. Jump is left on the D-pad and there is no movement controlls at all. Is there any way to fix this?
Zobrazeno 18 z 8 komentářů
< >
nims0c 29. srp. 2013 v 9.57 dop. 
Try changing the key bindings in buttonmap.cfg located in ~/Library/Application Support/Steam/SteamApps/common/Super Meat Boy/SuperMeatBoy.app/Contents/MacOS. Open it with TextEdit.
Milkaholic 29. srp. 2013 v 1.37 odp. 
it says:

keyboard
{
up="up";
down="down";
left="left";
right="right";
jump="space";
special="shift";
}

gamepad
{
jump="1";
special="3";
useanalog="true";
}

greasy grandma původně napsal:
Try changing the key bindings in buttonmap.cfg located in ~/Library/Application Support/Steam/SteamApps/common/Super Meat Boy/SuperMeatBoy.app/Contents/MacOS. Open it with TextEdit.
Milkaholic 29. srp. 2013 v 1.39 odp. 
I will try changing Jump to 0 instead of 1
Milkaholic 29. srp. 2013 v 1.50 odp. 
hmmm I am still getting the same issues. It hasnt helped. I have tried changing the keybindings and I have done a fresh reinstall of the game too...
nims0c 30. srp. 2013 v 6.31 dop. 
jay původně napsal:
So close to this working without any controller mapping software! I know this is an old post but I figured i'd put it up just incase anyone can figure out the last part?

for SMB with PS3 controller on a mac go to:

/Users/{YOUR_USERNAME}/Library/Application\ Support/Steam/SteamApps/common/super\ meat\ boy/SuperMeatBoy.app/Contents/MacOS/buttonmap.cfg

open the file with text editor and change the buttons under gamepad to:

jump="10";
special="9";

now R1 is jump & L1 is special, which is a little odd, as according to gamepad companion button 10 should be R2 and 9 should be L2. But it works, so what the hell...

The problem is that this only works for the first level you play. Meaning as soon as you beat a level, only R1 works as it should. Any ideas why this might be?

Taken from http://steamcommunity.com/app/40800/discussions/0/864948938198159711/

Try using these settings. Unfortunately, as he says, they may reset every level.
nims0c 30. srp. 2013 v 6.37 dop. 
If that doesn't work, and you've already tried a bunch of other combinations, perhaps try different software. Other than that, I'm not sure what to do. Development on this game has been pretty sloppy.
Milkaholic 30. srp. 2013 v 8.11 dop. 
I have currently got it working by setting the Config file to 99 with both so non of the controls interact with the mapped ones that I have set on Joymapper.

What I had to do was set the trigger button to + instead of the - value. For some reason the default scan set it so that it was toggled on until pressed, which would turn it off. So making it a + fixed the issue.

But allas still no way to get native support. The developtment for this game was poor past the XBLA version. You shouldnt put the game on Mac if it doesn't work and you have no intention on fixing it.
Naposledy upravil Milkaholic; 30. srp. 2013 v 8.12 dop.
JAMZU98 23. led. 2014 v 9.19 dop. 
If you have problems with your controllers on mac check this out: http://ndungeons.blogspot.fi/2014/01/mac-gamepad-not-working-tutorial.html
Zobrazeno 18 z 8 komentářů
< >
Na stránku: 15 30 50
Datum odeslání: 28. srp. 2013 v 1.59 odp.
Počet příspěvků: 8