Super Meat Boy > Algemene discussies > Details van topic
Veronica Fate: Moé Sniper 21 jul 2013 om 3:18nm
Super Error boy?
Howdy friends. Each time I try to run Super Meat Boy, I get an odd C++ Error. forcing the game to crash, any Ideas on a fix?
1-14 van 14 reacties weergegeven
< >
Zaven 21 jul 2013 om 3:44nm 
I think I'm getting the same one, if it is, I just have to open it again right after the crash and it works fine. Ive just been dealing with the crash for the first time after not playing for a while.
hopefully that helps
Scar Alouette 21 jul 2013 om 5:40nm 
Origineel geplaatst door Zaven:
I think I'm getting the same one, if it is, I just have to open it again right after the crash and it works fine. Ive just been dealing with the crash for the first time after not playing for a while.
hopefully that helps
Didn't happen anything for me, but try what Zaven says, maybe works.
[SMERG] xShadow421x 21 jul 2013 om 8:18nm 
Don't think I've ever got a C++ error, but it does crash the first time launching for me and usually runs fine after relaunching it. Does it crash everytime you attempt to run it?
Also, I know for some reason the game seems very picky about the resolution I use especially in fullscreen. Does yours boot into fullscreen or windowed? If fullscreen, you could try forcing it to start windowed by right clicking on it in your library, Properties, and Set Launch Options in the General tab and then put: -windowed
As I mentioned you could also try a different resolution if that doesn't do anything;
for ex.: -windowed -1280x720
(or any desired resolution your monitor/tv supports.) If it does run, change the settings how you like in-game obviously and then remove what you put in the launch options so it doesn't keep doing that. Hopefully you get it running, it's a fun game. Good luck!
Shmallish 21 jul 2013 om 8:39nm 
I'm about 98% sure I'm getting the same error as you are... I've tried re-installing the secondary launchers, but that hasn't worked. I tried what xShadow421x suggested, but that also did not work. I was going to contact the game's developers, but the link is leading me to an empty page. I really want to play this game and it's super frustrating that it seems like there is no way to fix it... :/
Veronica Fate: Moé Sniper 21 jul 2013 om 9:05nm 
Oy. Well, thanks for all the help guys. Kinda bogus we can't ger the real help.

And mine starts in windowed. Useing TV screen as a monitor.
KONY 2012 21 jul 2013 om 9:09nm 
dis game roolz
[SMERG] xShadow421x 21 jul 2013 om 10:38nm 
Origineel geplaatst door Shura Asagi:
Oy. Well, thanks for all the help guys. Kinda bogus we can't ger the real help.

And mine starts in windowed. Useing TV screen as a monitor.
Hmm, yeah unfortunately I'm not completely sure. Shame there's practically no infomation on this. If none of that does anything, all I can think of is maybe try manually reinstalling its prerequisites which consist of the DirectX setup & Visual C++ executables.
To do this, find the root folder for Steam where you had it installed (If you didn't change the directory, it defaults to "C:\Program Files\Steam" on 32-bit or "C:\Program Files (x86)\Steam" on 64-bit systems).
Then in the Steam folder: "\steamapps\common\super meat boy\Prerequisites".
You're looking for:
• DXSETUP.exe
• vcredist_x86.exe (Visual C++ For 32-bit) or
• vcredist_x64.exe (Visual C++ For 64-bit)
Then just run and repair/install the DirectX & correct C++ .exe for your system. Now if that fails, then yeah I have no idea at this point in time unfortunately. Beyond that, all I can suggest is the obvious things like veryfing the game cache, reinstalling the game, and/or checking that your drivers & stuff are up to date.
Veronica Fate: Moé Sniper 21 jul 2013 om 10:47nm 
Origineel geplaatst door SMERG xShadow421x:
Origineel geplaatst door Shura Asagi:
Oy. Well, thanks for all the help guys. Kinda bogus we can't ger the real help.

And mine starts in windowed. Useing TV screen as a monitor.
Hmm, yeah unfortunately I'm not completely sure. Shame there's practically no infomation on this. If none of that does anything, all I can think of is maybe try manually reinstalling its prerequisites which consist of the DirectX setup & Visual C++ executables.
To do this, find the root folder for Steam where you had it installed (If you didn't change the directory, it defaults to "C:\Program Files\Steam" on 32-bit or "C:\Program Files (x86)\Steam" on 64-bit systems).
Then in the Steam folder: "\steamapps\common\super meat boy\Prerequisites".
You're looking for:
• DXSETUP.exe
• vcredist_x86.exe (Visual C++ For 32-bit) or
• vcredist_x64.exe (Visual C++ For 64-bit)
Then just run and repair/install the DirectX & correct C++ .exe for your system. Now if that fails, then yeah I have no idea at this point in time unfortunately. Beyond that, all I can suggest is the obvious things like veryfing the game cache, reinstalling the game, and/or checking that your drivers & stuff are up to date.

Alrighty, thanks man. I'll give that a stab and hope for the best.
Viscero 22 jul 2013 om 7:15vm 
http://pcgamingwiki.com/wiki/Super_Meat_Boy#Crashing_Steam_version

I did the compatibility mode thing and so far it is okay. Can't say if it worked for sure, but I haven't experienced any crashes while alt-tabing anymore.
Zeromaeus 22 jul 2013 om 11:13vm 
I got this game recently and I'm having an error pop-up every time, too. Not sure its the same one though. This one says Fatal Error and something or other about mini dumps...

I've tried that fix above on the PCGWiki. It didn't work.
Laatst bewerkt door Zeromaeus; 22 jul 2013 om 11:20vm
am9zaA== 22 jul 2013 om 1:29nm 
meh
Shmallish 22 jul 2013 om 1:46nm 
Origineel geplaatst door The Deaf:
http://pcgamingwiki.com/wiki/Super_Meat_Boy#Crashing_Steam_version

I did the compatibility mode thing and so far it is okay. Can't say if it worked for sure, but I haven't experienced any crashes while alt-tabing anymore.


This worked for me too Yay finally someone found out the solution! Thanks!! :D
SIlencing Machine 22 jul 2013 om 9:52nm 
it happenes every time I try and play and works when I re-open.
Viscero 23 jul 2013 om 4:53vm 
Origineel geplaatst door Zeromaeus:
I got this game recently and I'm having an error pop-up every time, too. Not sure its the same one though. This one says Fatal Error and something or other about mini dumps...

I've tried that fix above on the PCGWiki. It didn't work.

I'm sorry to hear that :/ Did you use those settings for the actual .exe file under local content? Because the desktop shortcut is a steam executable or smth.


Origineel geplaatst door Shmallish:
Origineel geplaatst door The Deaf:
http://pcgamingwiki.com/wiki/Super_Meat_Boy#Crashing_Steam_version

I did the compatibility mode thing and so far it is okay. Can't say if it worked for sure, but I haven't experienced any crashes while alt-tabing anymore.


This worked for me too Yay finally someone found out the solution! Thanks!! :D

Hey I'm glad to hear that :) I spent a lot of time trying to find a solution as well (tried the DirectX reinstall etc) but this actually worked. Quite surprising really that something as simple as that could fix it.

EDIT: Crashed for me while alt-tabbing again. At least I haven't encountered any map or level crashes.
Laatst bewerkt door Viscero; 23 jul 2013 om 5:10vm
1-14 van 14 reacties weergegeven
< >
Per pagina: 15 30 50
Geplaatst op: 21 jul 2013 om 3:18nm
Aantal berichten: 14