Super Meat Boy > Общие обсуждения > Подробности темы
Greenybwa 9 фев, 2013 @ 14:47
SUPERMEATBOY C++ RUNTIME ERROR
HELLO I HAVE A C++ RUNTIME ERROR ON SUPERMEAT BOY FOR MONTHS AND STEAM DO NOTHING AND I CANT EVEN REGISTER TO TEAM MEAT TO ASK THEM BEACUSE OF THE FRIGGIN STUPID GAY ♥♥♥ SECURITY QUESTIONS THAT ARE BROKEN


PLEASE SOMEONE FIX MY PROBLEM BEFORE I KILL MYSELF


THANK U



STEAM U SUCK
TEAMMEAT U SUCK TOO


Показано 110 из 10 комментариев
< >
Greenybwa 9 фев, 2013 @ 14:52 
BUMP
Yukinari 10 фев, 2013 @ 20:04 
First of all, use proper spelling please. Second, insults get you nowhere. Third, this is stupidity on your part for not having microsoft C++ run time installed (correctly)
Greenybwa 11 фев, 2013 @ 10:36 
It used to work but I tried to change the resolution then it stopped working so I changed it manually still didnt work

So I reinstalled Microsoft C++ run time and it still didnt work

So I kept asking over and over to the fourm and steam company to help me but no-one has so I got frustrated
powerturdplus 12 июн @ 18:23 
In the game library right click on SMB and select properties from the list. The first tab that opens up should have a button near the bottom of the window called "launch options" Click it to open a small command line then type or copy and paste -windowed then close the window, apply changes if needed and then run the game. It should work fine after that. The command forces the game to start in windowed mode but if you like full screen you can change it back while in game.

The first suggestion fixed my problem but depending on your OS and settings you may need to take further steps which I have listed below. Try my suggestion above before anything else and leave it applied even if you need to take the steps below.

If you are running a modern version of windows with UAC (user account control) enabled then your OS may be blocking access. To change this go to whichever drive you have steam installed on (I will use C: as an example) and find the following folder C:\Steam\SteamApps\common\SuperMeatBoy From there look for the .exe file that runs the game and right click on it then select properties. Once the next window opens go to the compatibility tab (note that some versions of windows require you to check an option on the first tab that says unblock before you can use them do that in addition to the following if needed) and scroll to the bottom then check the box that says "Run As Administrator" apply the changes and click ok to close and then run the game.

If none of this works then try deleting the game completely and reinstalling it and then try these suggestions again. If you have a problem even after that then you may want to ensure that you have your runtime installed correctly. Don't ask around on steam forums for that info if that is the case because it is much quicker to get answers from tech forums, Yahoo Answers, You Tube and Microsoft. Steam is not responsible for the c++ run time that would be the responsibility of Microsoft and the specific game developers that use it.

Furthermore, I would like to make it clear that I have responded to this in order to help other people because this question is the first one that pops up on the subject when it is Googled. In the future, if you really need help then try asking for it calmly and clearly and refrain from baseless insults because as you have hopefully learned by now, they will get you nowhere.
Greenybwa 14 июн @ 8:25 
Tried everything you said still does not work, also I made this forum post like 3 times this was the third time where I got angry because no-one replied or could fix it from the previous 2. I already tried going on tech forums but they couldn’t help me either.
Последний раз отредактировал Greenybwa; 14 июн @ 8:26
xD1337x 14 июн @ 17:20 
Just bought this game and was having problems launching it too. What i just did to get it to work; Right clicked [instal dir]\SuperMeatBoy.exe > Properties > Compatibility > Select Change settings for all users > And selected options:
Run in 640x480 Screen Resolution
Disable Visual Themes
Disable Display Scaling on high DPI settings
Run as Administrator

Not sure which of these settings got it working, but it's working now.Game launches full screen even with the resolution setting setting in compatibility.

Hope this helps
powerturdplus 15 июн @ 20:03 
Ok, are you sure that you have your runtime installed properly? This should not even be a manual install unless you have windows updates turned off or you have uninstalled it and then tried to reinstall it. If you are using more than one HDD then you had better make sure that either your OS, Steam and c++ are on the same drive or that you have RAID configured properly. If you have a system restore point that you can jump to where it is still installed as it should be then it may save you a lot of trouble. If not I can't think of a reason why a person working for Microsoft would not be able to assist you properly. The company spans the globe and answers hundreds of millions of questions every day in every language used in the modern world. Don't take it personally if you have had a run of bad luck, just keep asking around and maybe try calling a support number, somebody will be able to help you.
Greenybwa 18 июн @ 8:43 
Изначально опубликовано powerturdplus:
Ok, are you sure that you have your runtime installed properly? This should not even be a manual install unless you have windows updates turned off or you have uninstalled it and then tried to reinstall it. If you are using more than one HDD then you had better make sure that either your OS, Steam and c++ are on the same drive or that you have RAID configured properly. If you have a system restore point that you can jump to where it is still installed as it should be then it may save you a lot of trouble. If not I can't think of a reason why a person working for Microsoft would not be able to assist you properly. The company spans the globe and answers hundreds of millions of questions every day in every language used in the modern world. Don't take it personally if you have had a run of bad luck, just keep asking around and maybe try calling a support number, somebody will be able to help you.

yes
powerturdplus 18 июн @ 9:20 
Well then all I can think of is that you have some sort of compatability issue. You said that it worked for a while before right? It's likely that it shut down in the first place because you set an option that your computer or OS didn't like but I would bet my last dollar that the problem you are having now is as a result of something that you changed when you were trying to fix it. The best I can do for you is to tell you that you need to retrace your steps to the most finite detail or use a restore point. Make absolutely sure that -windowed with the minus sign first is the exact and only command in the launch options before you go further because that works for most people.
Greenybwa 19 июн @ 13:19 
dude i just changed my game resolution and then it died i didnt do anything the games just bad and the customer support is worse

paid top dolla and i cant even play the damn game
Показано 110 из 10 комментариев
< >
На страницу: 15 30 50
Дата создания: 9 фев, 2013 @ 14:47
Сообщений: 10