Super Meat Boy > 一般討論 > 主題細節
Mount C 2013 年 02 月 4 日 @ 上午 1 時 55 分
Controller help
The game registers the buttons on my controller incorrectly and it's confusing going through tutoriasl where the buttons on the screen don't match the buttons you have to press. What's the easiest way to change the controls for the gamepad in this game?
顯示 1-15,共 16 則回應
< >
KittenCanaveral 2013 年 02 月 4 日 @ 上午 3 時 31 分 
what kind of controller are you using?
Hp*H@ppy_Unusual 2013 年 02 月 4 日 @ 上午 7 時 22 分 
Same problem here. I'm using "Defender Game Racer Wireless Pro" it's like a gamepad from sony play station.
Index Finger 2013 年 02 月 4 日 @ 上午 9 時 53 分 
Try disabling HID compliant game controller. Press start (in windows), right click in computer - manage. In the menu at the left, under system tools, look for Device manager. Open the submenu "Human interface devices" and disable said thing. The buttons should match now
Mount C 2013 年 02 月 4 日 @ 下午 6 時 09 分 
Kateweb 發表:
what kind of controller are you using?
An Xbox-style controller. I'm not sure what company it's made by, but what I can say is it's not made by Logitech, the left thumbstick is parralel to the A B X Y buttons and it's not compatable with many Steam games with only "Partial controller support." There are quite a few games where the setup of the buttons was wrong, but I was able to fix it those times because the game allowed you to modify the controls.


luis1761 發表:
Try disabling HID compliant game controller. Press start (in windows), right click in computer - manage. In the menu at the left, under system tools, look for Device manager. Open the submenu "Human interface devices" and disable said thing. The buttons should match now
That didn't work. Once it was dissabled, the game wouldn't register it at all, and when I enabled it again, it still registered the buttons incorrectly.
最後修改者:Mount C; 2013 年 02 月 4 日 @ 下午 6 時 16 分
Index Finger 2013 年 02 月 4 日 @ 下午 8 時 49 分 
Yes, there is one of them that disables the control. I once had that exact problem, and was resolved disabling an HDI. I cant recall exactly which one. May you want to try some of them, but not at the same time.
最後修改者:Index Finger; 2013 年 02 月 5 日 @ 下午 1 時 03 分
Hp*H@ppy_Unusual 2013 年 02 月 5 日 @ 上午 3 時 56 分 
Try to play with Xpadder programm maybe you gonna make something, but sopmetimes there's a problem when game and programm together noticing gamepad, try to connect gamepad and starting programm after running game. ^_^ Sometimes game won't notice gamepad after if it connected after game launch, but xpadder see it every time, so maybe in this way you can use xpadder. Xpadder is a programm for attaching keyboard buttons to gamepad. So you can use keyboard buttons and attach them right.
Fluffytme 2013 年 02 月 5 日 @ 上午 8 時 14 分 
luis1761 發表:
Try disabling HID compliant game controller. Press start (in windows), right click in computer - manage. In the menu at the left, under system tools, look for Device manager. Open the submenu "Human interface devices" and disable said thing. The buttons should match now

I'm using an official wired xbox controler and can confirm that this works
Hp*H@ppy_Unusual 2013 年 02 月 5 日 @ 下午 12 時 21 分 
That didn't worked for us... Just like it's totally off. =3
Index Finger 2013 年 02 月 5 日 @ 下午 1 時 06 分 
Filter62 發表:
That didn't worked for us... Just like it's totally off. =3

Sorry, i forgot to say that i tried this with a wired xbox controller too, so i dont know if this would work for others pads as well
Kitty ❤ 2013 年 02 月 6 日 @ 上午 9 時 20 分 
I'm also using the Official Xbox 360 for PC controller and it's working fine.
KittenCanaveral 2013 年 02 月 7 日 @ 上午 10 時 17 分 
I hate it when a bug cant be reproduced ... makes it harder to help people
FESTIVE ALPHA MALE 2013 年 02 月 9 日 @ 上午 3 時 58 分 
i cant even use my controller on smb i can connect it but not use it help i have xbox and ps3 none of them work
memoryman18 11 月 30 日 @ 下午 4 時 15 分 
You have to unplug the controler, launch the game, then plug the controler back in. This should fix any problems you are having.
Index Finger 11 月 30 日 @ 下午 4 時 30 分 
memoryman18 發表:
You have to unplug the controler, launch the game, then plug the controler back in. This should fix any problems you are having.

My ♥♥♥♥ing god, this thread is almost a year old. Look before you reply please
Hp*H@ppy_Unusual 11 月 30 日 @ 下午 5 時 18 分 
Index Finger 發表:
memoryman18 發表:
You have to unplug the controler, launch the game, then plug the controler back in. This should fix any problems you are having.

My ♥♥♥♥ing god, this thread is almost a year old. Look before you reply please
Same feeling XD
顯示 1-15,共 16 則回應
< >
每頁: 15 30 50