Super Meat Boy
Michael the Narwhal 5-0 May 4, 2014 @ 12:46pm
Controller Doesn't Work on Linux
I have a Logitech Precision controller. The controller works great for a lot of things, including SMB on Windows on the same machine. It doesn't work with this game on Linux, for whatever reason. Steam seems to detect the controller just fine, but SMB doesn't.

Any suggestions? I'm running Ubuntu 14.04 (64-bit), I've also tried on Ubuntu 12.04 with no luck.
< >
Showing 1-7 of 7 comments
Thunderdome Fanatic May 5, 2014 @ 4:32pm 
glass May 6, 2014 @ 3:34pm 
I can't really help you because I don't have your controller/set-up.

However, I'd like to report that my logitech f710 works on arch linux 64bits.
littlejawa May 7, 2014 @ 5:24am 
I have the same issue - Ubuntu 14.04 64bits, my gamepad works on Steam (Big Picture) and other steam games, but SMB doesn't seem to see it...
###O?qÿáÓ May 10, 2014 @ 11:00am 
Try Big Picture mode. In the settings you can configure your controller. Then just start the game and it should work.
Victor Xubuntu powered Jul 9 @ 9:37am 
Same problem here. I had tried Big Picture mode, but can't configure all the buttons (axis). Playing the game there is only up or down, and left or right, but not all together...
「Starmate 」 Jul 11 @ 5:49am 
same here!
ShizZ Aug 5 @ 11:51am 
i have this problem to in ubuntu gnome 15.4

i install ubuntu_xboxdrv from

By default, triggers are not enabled as z-axis, but as buttons. To change, edit /etc/default/xboxdrv and change TRIGGERS_AS_BUTTONS to false.

now if i start play SMB in BigPicture mode - gamepad (xbox360controller) work good.
but if i start play SMB in standart steam window (not BigPicture) gamepad not work in SMB.
Last edited by ShizZ; Aug 5 @ 11:51am
< >
Showing 1-7 of 7 comments
Per page: 15 30 50