TheBrothersGamme Aug 7 @ 12:33pm
Trouble Recording
Every time i start recording, meat boy starts spazzing out. i looks like he keeps repetitively jumping very quickly. It only happens when i am recording and stops as soon as i stop recording. I am using Microsoft Expression Encoder 4 screen capture to record. I've read about the glitch happening to other people but nothing about it happening because of recording. Anyone have any ideas?
Showing 1-15 of 18 comments
< >
horheristo Aug 7 @ 3:37pm 
Tried fraps?
meanfactor Aug 7 @ 5:53pm 
Speed runner's actually use that glitch on purpose to quickly walljump in certain areas.

I think they hold the jump button, bring up the pause menu and release the jump button. Then un pause and then Meat Boy is auto jumping on every frame after that.

As for recording, Dxtory is even better and has more advanced options then Fraps.
TheBrothersGamme Aug 7 @ 8:23pm 
I'm using MEE4 is because its free, doesn't leave a watermark, and lets me record for 10 mins (as opposed to 30 seconds). It also lets me record in HD.
Syntax Aug 8 @ 10:31am 
Originally posted by meanfactor:
Speed runner's actually use that glitch on purpose to quickly walljump in certain areas.

I think they hold the jump button, bring up the pause menu and release the jump button. Then un pause and then Meat Boy is auto jumping on every frame after that.

As for recording, Dxtory is even better and has more advanced options then Fraps.

You're right about how to activate the autojump glitch but that's not what this is.

There are 3 things you should make sure of when recording.

1.Your FPS must be limited to 60 (Not necessarily the FPS of the recording but the FPS of the game.) This is whats causing your problem I am pretty sure.

2. Turn off unnecessary apps. You might think meat boy is lightweight but it's well known for crazy lags when recording, this is why alot of top speedrunners reduce their settings when running.

3. Set meat boy and the recorder to high prioirty tasks unless your pc would be unstable in this case. You can do this by going to the processs in task manager, and go to set priority in the right clck menu
TheBrothersGamme Aug 8 @ 2:06pm 
How do i change/limit the fps of the game? I can't find an option for it.
Syntax Aug 8 @ 5:40pm 
Funnily enough I'm not sure :D

I use my graphics card control panel to do it. If you are using an Nvidia card you can definitely do this, otherwise I'm not sure. Also many recording programs can force it as well, I use obs and it has a limit fps of application function but I dont know if there is a game specific way
dimitry10 Aug 8 @ 7:01pm 
I had the same problem when I broadcasted the game on tinychat, using manycam. When I streamed it on twitch, using open broadcast software it worked great though.
TheBrothersGamme Aug 8 @ 9:23pm 
AH i DO have a Nvidia card, but sadly, haven't been able to figure out how to use it to limit my fps.
Syntax Aug 9 @ 2:01am 
Originally posted by TheBrothersGamme:
AH i DO have a Nvidia card, but sadly, haven't been able to figure out how to use it to limit my fps.

Hopefully the same method I am using will work.

Go to search on your computer and type in Nvidia.
One of the results should be Nvivia control panel, click into this:

If you have an older card this wont work but on the left you will see manage 3d settings, go into that.
You should see a global settings and application settings there.
Where it says application settings, select meat boy from the drop down list and enable v sync (it shows up near the end after selecting the game)
TheBrothersGamme Aug 9 @ 8:19am 
Originally posted by Scarlet:
You should see a global settings and application settings there.
Where it says application settings, select meat boy from the drop down list and enable v sync (it shows up near the end after selecting the game)

Theres two tabs. One is "global settings" and one is "program settings". In global settings ive used the vsync option to keep it forced on and that didnt help. Also I cannot find/add SMB into the program settings list because I don't have the .exe file on my computer. All I can find is the internet shortcut for steam to run it. But also I don't play SMB in full screen, isn't vsync affected by that?
Syntax Aug 9 @ 9:37am 
your exe file should be here C:\Program Files (x86)\Steam\SteamApps\common\Super Meat Boy

Why dont you play in full screen?
TheBrothersGamme Aug 9 @ 10:46am 
Oh thanks!
And i don't play in full screen because i record in 1280x720p for better quality/performance. My monitor is 1080p so when i size game to 720p it's not fullscreen anyore XD.
Last edited by TheBrothersGamme; Aug 9 @ 10:47am
TheBrothersGamme Aug 10 @ 10:57am 
So when i play in full screen or if im in windowed with the resolution set to 1080p then he stops spazzing out. I set the priorities of the recorder and SMB to very high. The problem is now i have to choose between a little lag (probably cuz my comp isnt good enough to record in 1080) and him spazzing.

Thank you so much for the help Scarlet!
Syntax Aug 10 @ 11:06am 
no problem, one last thing to try is lower all other options, (Pick performance over qualty,) in application setting on Nvidia control panel, dont know if it will make a difference but worth a shot
TheBrothersGamme Aug 10 @ 9:31pm 
The glitch is still hapening. It's just really random. sometimes its a few little hops. sometimes he spazzes out for a few seconds, but it's much better than the constants spazzing. i don't get it hahah. But i will try that.
Showing 1-15 of 18 comments
< >
Per page: 15 30 50