Hunter Normandy Jul 11, 2013 @ 5:51pm
(9/12/13 NEW UPDATE ON THIS) Possible Fix For The "Load Times / Freezing" Problem [TEMP FIX FOUND CHECK HERE]
**UPDATE 7/12/13 9:48PM NORTH EASTERN TIME**
**LOOK AT BOTTOM FOR TEMP FIX I FOUND**
*****CHECK BACK HERE EVERY DAY! I FIND MORE AND MORE PROBLEMS AND FIXES GUYS YOU'LL LOVE THIS ♥♥♥♥****

>>>>>>>>>>9/12/13 UPDATE<<<<<<<<<<<<<<<<<
go to the last page and find my hugeass comment with alot of spoiler marks in it,
it will explain the new ♥♥♥♥.

I think i found the fix.

MY INITIAL RESEARCH AND FINDINGS:

After having numerous occurrences of this problem and others related to optimization and freezing/hanging crashing after steampipe. and also from gathering copious amounts of information from a large number of friends and random people.

I compared their actions with their problems.

Iv already tried the fix and it works, but i have recreated the error (on purpose) to test other ways to fix it and also double confirm that i have it working.

Ill post the steps once i am finished. in maybe 30 or so minutes.


MY THOUGHTS:

The issue was no doubt caused by steampipe, but it is not CURRENTLY the reason why the problems at hand persist. there may have been corrupted files during initial steampipe conversions/updating that lingered around in their respective file paths.
causing horrendous problems.

It is NOT (As i have confirmed) a workshop issue. not a number of mods issue as i have a really powerful rig, and had absolutely no problem with load times before steampipe.


IF YOU WANT TO HELP ME SOLVE THIS FURTHER! PLEASE RELAY THIS INFORMATION IN A COMMENT BELOW!

-Do you have a garrysmod folder in steamapps/USERNAME/garrysmod?
-Do you have a garrysmod Folder in steamapps/COMMON/garrysmod?
-Do you have a garrysmod folder in both simultaneously?
-If yes to both, which one contains your addons? (.gma's) one or the other or both?
-Have you downloaded outside mods that werent from the workshop.
-If yes to which garrysmod folder?
-Did you have problems during the initial Steampipe conversion / updates
-Did you at any time opt into the Development Branch Beta?

other very useful information you can give me:

-How many mods do you have installed? i have 689 and never had problems before this.
-How LONG do the freeze times drag on for? PLEASE BE SPECIFIC, dont say 5 years.
dont exaggerate, if you dont know go run garrysmod right now and time it for me.
-How many times does it freeze, and at what phase, during startup?
for me its once before Facepunch logo disappears. once when menu is done, and then once when i pick my map.
-do you have any crash to desktops? or none if you wait it out.
-if you get errors are they no window splash crashes or do they actually display an error?



I THANK YOU FOR SUBMITTING YOUR INFO AS IT WILL HELP ME FIX THIS NASTY ♥♥♥ ♥♥♥♥ING GLITCH THATS GAY AS ♥♥♥♥BALLS!

**************MAJOR UPDATE READ THIS IMPORANT OMG LOL FIX SERIOUSLY**************

just kidding, im not quite there yet HOWEVER I DID FIND A VERY EASY WORKAROUND THAT DOES WORK FOR ALL TO USE IN THE MEANTIME.
follow this procedure EXACTLY!


FIX #1
1- startup game
2- in main menu disable all addons
3- pick your map (you should still get a slight freeze hang. but it should be absolutely no where near its length span with even 1 mod active)
4- ingame go to pause and re-enable all mods. you shouldnt freeze for that long
4b- if you freezing too bad at this point, run gmod in windowed mode. the second you freeze go in task manager and set Awesomium process to HIGH, then hl2 to HIGH IN THAT ORDER! it should reduce the freeze time by roughly 65%
4c- if you already have multiple Awesomiums present, you werent fast enough to set priorities to high.
5- go into console, either type retry or map (mapname) if you want a different map than the one you chose first.

this temp fix helps remove the following:
-crash on first step
-Greatly relieves load time struggles.


FIX #2:
1- Remove Silverlans Fallout NPCS addon
OP:
-dark messiah and Eye Divine Cybermancy SNPCS also cause problems,
especially when combined, remove these aswell.

this temp fix helps remove the following:
-Crash on first step
-slight relief to load time struggles

FIX #3:

1- If you have a Mac and have iObit installed... uninstall it

This temp fix helps remove the following:
-completely fixes everything from what i heard i dont have a mac tho.

FIX #4:

1- Remove any unnecessary workshop maps you have. since awesomium wants to test all downloaded maps for no reason more dl'ed maps = longer freeze time.
i now have 0 workshop maps. and have no freeze time.

as for the crash on first step. its really hard to tell, sometimes its a code error ,sometimes its just 1 faulty addon which requires combing through them all to find the culprit.

other helpful steps:

-verify cache (right click gmod in games library / properties / local files / verify
-remove garrysmod folder and any other steampiped games folders from USERNAME.
either delete them or move them somewhere else.
-if you want to try reinstalling gmod, please do it this way. its the most effective procedure.
0(optional). unsub all addons first
1. delete all gmod folders entirely
2. do the right click / delete local content in the steam library for gmod
3. disable cloud storage.
4. restart pc or steam
5. install gmod and run.

ill update later with more findings.. spread the word.
Last edited by Hunter Normandy; Sep 12, 2013 @ 8:07pm
Showing 1-15 of 651 comments
< >
Kurt Cobain Jul 11, 2013 @ 6:01pm 
I just Posted a thread about Complete freeze time untill i exit the game. The game doesnt respond and this only started occuring after the download and integrating of L4D2
Bobo the Monkey Jul 11, 2013 @ 6:17pm 
I just got L4D2 so would it be wise to download it?
Hunter Normandy Jul 11, 2013 @ 6:44pm 
guys none of that information is helpful. read my post.

all newcommers look at the end of page 39
Last edited by Hunter Normandy; Sep 12, 2013 @ 8:47pm
Hunter Normandy Jul 11, 2013 @ 7:16pm 
My fix is working. but i need more people to give me info so i can cross reference.
Periwinkle Tippytoe Jul 11, 2013 @ 7:30pm 
It is in the common folder, never installed to the user folder after I deleted everything and reinstalled

Common contains gmas

It freezes at the blue loading screen with the loading cursor, goes not responding and that's it. Nothing else. I guess it's my windows settings that causes it not to just close immediately, I like to let it wait indefinitely because of the softwares that I use. So it just waits there at the blue screen.

I've done too much to explain to try and get this working. Not going to go through every little detail, but if you can think of it I probably did it. Just tired and want to game, got my wisdom teeth out today and I am just trying to relax.
Periwinkle Tippytoe Jul 11, 2013 @ 7:30pm 
Can you just give the fix bro so I have something els-e to try. I mean seriously
sk8tbdkid Jul 11, 2013 @ 7:43pm 
I'll number your questions so I am just giving the answers:

1. Yes
2. No
3. No
4. Username/garrysmod
5. Yes
6. Username/garrysmod
7. No
8. No

Section 2:

1. 419 (plus 7 downloaded from garrysmod.org)
2. Between 30 seconds to 4 minutes
3. It freezes when at the main menu (and the workshop addons do not appear until after it unfreezes), it freezes when selecting a map, it freezes when I disconnect or exit a session.
4. No crashes to desktop (Although on some occasions it minimizes to the desktop)
5. No error messages
Hunter Normandy Jul 11, 2013 @ 7:45pm 
oh i also forgot. does anyone crash ingame the second they move forward?
sk8tbdkid Jul 11, 2013 @ 7:53pm 
I don't.
Hunter Normandy Jul 11, 2013 @ 7:57pm 
also for further reference i noticed everytime the game freezes... another awesomium process.exe opens, the more times it freezes the more awesomiums just running eating up CPU.

this is very vital information that im emailing to Garry Newman right now.
Tessa K. Pegram Jul 11, 2013 @ 8:54pm 
Originally posted by Hunter Normandy:
oh i also forgot. does anyone crash ingame the second they move forward?
Yea, this is my problem.
Periwinkle Tippytoe Jul 11, 2013 @ 9:05pm 
Glad to see Ace on the Case. Get er done, sparky.
Abernathy Jul 11, 2013 @ 10:46pm 
When I get home, I'll be checking things and do a test play. I get all the problems except for crash when moving anywhere
Tessa K. Pegram Jul 11, 2013 @ 11:11pm 
I have read through that having a high number of addons may cause the problem, I have 75.
Periwinkle Tippytoe Jul 12, 2013 @ 12:12am 
Originally posted by Col. Saeko K.M. Pegram:
I have read through that having a high number of addons may cause the problem, I have 75.

Deleting your add ons will do nothing but bother you when you have to download them again.
Showing 1-15 of 651 comments
< >
Per page: 15 30 50
Date Posted: Jul 11, 2013 @ 5:51pm
Posts: 651