CarnageJD Dec 6, 2012 @ 10:26am
DirectX Runtime is out of date. HELP!
Every time i load up garrys mod, it stops loading and comes up with 'Your DirectX Runtime is out of date. Download and install this file from Microsoft.' I've downloaded what it asked me to and it says i have nothing to install or update. Anyone have any ideas?
Thanks.
Showing 1-15 of 46 comments
< >
Ninten Dec 8, 2012 @ 6:10pm 
same problem, anyone here to help?
Iaeyan Elyuex Dec 9, 2012 @ 7:08pm 
I'm having the exact same problem. My other computer has the same version of DirectX as the problem computer, but it runs Gmod just fine.
Streamlined Dec 26, 2012 @ 6:32am 
Try using this version, worked for me running windows 8: http://www.softpedia.com/get/Programming/SDK-DDK/DirectX-Software-Development-Kit.shtml
CarnageJD Jan 18, 2013 @ 12:39pm 
I finally worked out how to fix it. Not sure if anyone here still need help but just in case you do, all you need to do is go to http://www.dll-files.com/dllindex/dll-files.shtml?d3dx9_40 and download the zip file, extract it and then put the dll file into your garrys mod folder. You just need to rename it so that it doesn't have capital letters in the file name. Run garrys mod and it should work! :)
HaybailsOG Feb 2, 2013 @ 1:31pm 
Yeah im having the exact same problem. i bought gmod yesterday and i keep getting the direct x out of date message go to microsoft and download direct x. but then theres another problem. as soon as i start installing it it crashes and comes up with an error message saying "An internal system error occurred. Please refer to DXError.log and DirectX.log in your windows folder to determine problem". so i look in the windows folder and cant seem to find any of the folders. please someone help me i really want to play the game, thanks!
HaybailsOG Feb 2, 2013 @ 2:58pm 
But i Just tried your way CarnageJD it works! thank you so much! i just made a hoverbatha nd shot father grigori in the head, such fun:D
Lethal Clone Feb 5, 2013 @ 8:59am 
I' m hoping what Carnage said will work, but where do I find my Garry's Mod folder?
Lethal Clone Feb 5, 2013 @ 9:08am 
Ok, what Carnage said helped me so much, I wish I had come here before spending hours searching threw the microsoft forums :D
Le Taco Feb 6, 2013 @ 4:41pm 
Where do you find the Gmod folder?
CarnageJD Feb 6, 2013 @ 6:23pm 
C:/Programme Files (x86)/Steam/Steamapps/(Your Username)/garrysmod

Hope that helped :)
stone_ed_eagle Feb 6, 2013 @ 7:47pm 
i have the same problem, but i tried this and it didn't work :/ any other suggestions?
CarnageJD Feb 6, 2013 @ 7:51pm 
I'm really sorry, i know how frustrating it is trying to get it to work, but other than what i've put im all out of ideas. All i could say is make sure you did everything i put in the post, especially renaming the file, for some reason it wont work unless its lower case.
=[o.W.n]= dustojnikhummer_CZ Jun 23, 2013 @ 12:02am 
i have same problem. i have on my win7 directx11 and gmod need 9 but in settings is Hardware Level 8.0 can someone help??
Littlehawk98 Jul 2, 2013 @ 10:09pm 
I also received this message, and followed the included instructions. Now, clicking Play for Garry's Mod gives me a black screen, followed by an error message from my monitor, "Unsupported Video Signal". I have to hit the Windows key to get back to seeing anything from my computer, and close Garry's Mod from my taskbar. I tried all of the above suggested fixes, but nothing has changed. Ideas? Please help! I'm running Windows 7 64-bit (6.1, build 7601).
Last edited by Littlehawk98; Jul 2, 2013 @ 10:10pm
eliteforce Jul 29, 2013 @ 11:33am 
I tried carnagejd's way and I downloaded the zip file and when I took the file and tried to put in the Garys mod file it would not work any advice
Showing 1-15 of 46 comments
< >
Per page: 15 30 50