vonmon2 Nov 30, 2012 @ 8:04pm
Steam Error: No SteamUser
Whenever I try to start Gmod, the screen turns a light blue like it's supposed to and it says "Loading..." in the bottom right corner. Then the game instantly shuts down and says:

Steam Error: No SteamUser

-Make sure that Steam is up to date
-Try restarting your PC.
-Try Garry's Mod -> Delete Local Content

Please let me know if you solve this bug!


I've tried all of those things, but nothing's working. Is this happening to anyone else?
Showing 1-15 of 52 comments
< >
[areo] Bwah Dec 1, 2012 @ 7:47am 
I've got that problem as well.
Goelian Dec 6, 2012 @ 10:34am 
me to ;(
Nickerdoodle Dec 6, 2012 @ 1:41pm 
I got the same thing only it doesn't shut down the game. I've tried reinstalling, restarting my computer and steam just updated yesterday. PLEASE HELP!
TheFeelTrain Dec 6, 2012 @ 3:48pm 
I just downloaded a Garry's Mod update and mine is doing it to :(
John Lennon Dec 6, 2012 @ 3:50pm 
It broke because of the update. Screw garry.
Hufflez Dec 6, 2012 @ 4:36pm 
me to :(
Juicy Dec 6, 2012 @ 4:50pm 
SAMETHING TO ME!!! WHAT IS GOIN ON!?!?!?! I TIRED EVERYTHING!!

[PN] Napolean Bonerfarts Dec 7, 2012 @ 4:16am 
I had another error with mac 10.5.8 so i updated it hoping to fix it. It didn't but I'm guessing all of you have 10.6.8 like me?
Spooky Scary Skeleton Dec 7, 2012 @ 12:18pm 
Actually I've got 10.7.5
Dunkaroo Dec 8, 2012 @ 8:05am 
same thing happening with me. I just got garrys mod. @viralworld your right, screw garry
Sue Dec 8, 2012 @ 9:29am 
Originally posted by vadertrader101:
same thing happening with me. I just got garrys mod. @viralworld your right, screw garry

It should be fixed by recent patch.
Eve Brea Jan 7, 2013 @ 1:13pm 
I have the same error, probably is because the patch.
Shadetrap [TC] Mar 8, 2013 @ 8:51am 
Same
Shadetrap [TC] Mar 8, 2013 @ 1:26pm 
Try “Verify Integrity of Game Cache” under preferences, when right-clicking Gmod.

If it doesn’t work, try uninstall your latest workshop subscriptions, until the time when your Gmod worked fine.

And if THAT doesn’t work either, well, just keep uninstalling your addons, (one bunch of a time, if you have many, I had over 500 subscribed items (maybe make a collection, if you want to find all your subscribed items again)), and “Verify Integrity of Game Cache” each time you want to try start gmod. This point worked for me.
Last edited by Shadetrap [TC]; Mar 8, 2013 @ 1:27pm
RoccoInABun321 Jun 5, 2013 @ 5:03pm 
THIS is so stupid, steam. We paid for this ♥♥♥♥ can we get some ♥♥♥♥ING support?! HELP
Showing 1-15 of 52 comments
< >
Per page: 15 30 50
Date Posted: Nov 30, 2012 @ 8:04pm
Posts: 52