Bargomorphic Mar 16, 2013 @ 7:27pm
"Error: Could not load Library Client" Fixed!!!
Alright, you might be thinking,"Great. Another guy to tell me to rename another folder.", but no! I'm here to help you out!

All you have to do is 2 simple steps:

1) Copy everything from "C:\Program Files\Steam\steamapps\{Your Username}\garrysmod" to "C:\Program Files\Steam\steamapps\{Your Username\garrysmod\garrysmod"...(NOTE: If it asks you if you want to overwrite something, do it!)

2) Copy everything from "C:\Program Files\Steam\steamapps\{Your username}\garrysmod\garrysmod" to "C:\Program Files\Steam\steamapps\{Your username}\garrysmod"...

Now launch your game. This should work (Cause it's worked for other people, as well!) If this doesn't help, please notify me... enjoy! :D
Showing 1-12 of 12 comments
< >
blode Mar 24, 2013 @ 6:53pm 
thanks a ton
been trying to fix this all day, first thing that worked
Jag vet vart du bor. May 28, 2013 @ 12:24pm 
This didn't work for me. I've had this problem for a week now. I believe i tried this very step before as well. But yet i still get ''couldnt load library client'', pls help ? :/ I tried everything
Mr.Magnificent Jun 9, 2013 @ 1:46pm 
Does any one have a fix for this on Linux mint 14?
I'm looking all over the place to find a fix but all I get a windows fixes.

Please help.
BubbatheVTOG Jun 11, 2013 @ 10:50am 
Originally posted by Mr.Magnificent:
Does any one have a fix for this on Linux mint 14?
I'm looking all over the place to find a fix but all I get a windows fixes.

Please help.

bump for arch linux 64-bit.
Last edited by BubbatheVTOG; Jun 11, 2013 @ 10:50am
▓▒░ H3g3m0n ░▒▓ Jun 13, 2013 @ 11:06am 
Originally posted by bubbathevtog:
Originally posted by Mr.Magnificent:
Does any one have a fix for this on Linux mint 14?
I'm looking all over the place to find a fix but all I get a windows fixes.

Please help.

bump for arch linux 64-bit.

"Error: Could not load Library Client" is a problem with x86_64 systems due to gmod being a 32bit application and needing 3d bit libraries. Specifically you need the 32 bit version of gconf and its dependencies.

For Arch install lib32-gconf (It's in the AUR):
yaourt -S lib32-gconf

For Ubuntu (and I believe Mint and other Debian derivatives) install ia32-libs:
sudo apt-get install ia32-libs
Last edited by ▓▒░ H3g3m0n ░▒▓; Jun 13, 2013 @ 11:10am
Mr.Magnificent Jun 13, 2013 @ 12:08pm 
Now when I load Garrys Mod it Says " could not load library 'gmhtml' (looking for interface JGMHTML001) ".

What do I do now?
You'll Never Defeat Andross Jun 17, 2013 @ 9:04pm 
Thank you H3g3m0n!
Oreocat Jun 21, 2013 @ 2:27pm 
Worked for me on Mint 15, thanks H3g3m0n
Skorpion3L Jun 25, 2013 @ 3:09pm 
Thank you H3g3m0n!
Leedle Leedle Leedle Lee Jul 1, 2013 @ 6:36am 
What about a Macintosh 10.5?
How does the system work on a Mac?
EDIT: I went to my Steam > steamapps > [My User] and I can't find a folder named garrysmod. I've downloaded it, just never been able to open it. I only found a file named sourceinit osx
Last edited by Leedle Leedle Leedle Lee; Jul 1, 2013 @ 6:39am
You'll Never Defeat Andross Jul 10, 2013 @ 3:19pm 
try looking in Steam > steamapps > common
Unix [MS] Jul 13, 2013 @ 8:13pm 
Can anyone help me, my friend got the same problem and we it doesn't work -_-
Plizz help

- M.S - MR - KLEIJN
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Mar 16, 2013 @ 7:27pm
Posts: 12