Garry's Mod

Garry's Mod

View Stats:
Queen Lisabear Jan 10, 2014 @ 3:12pm
Low FPS on Garry's Mod
Hello Steam community,

I have a problem with my frame rate in Garry's Mod. While in spectator, I can easily get nearly 200 FPS. However, once I play myself, it drops down to 30 FPS or lower. Particularly when playing the Murder mode, I get 30 FPS as a bystander but it goes to 15 when I'm the murderer. As you can imagine, playing at such low FPS is a huge disadvantage.

I've played on various Murder servers and my frame rate is always like this. However, there was only one server where I could have constant 60 FPS as a bystander (and 30 as a murderer). This leads me to believe that my FPS issue does not have to do with my computer, but rather the game itself. I would also like to point out that my fps_max is set to 60. I'm just wondering if anyone knows a solution to this issue. And does anyone know why on this one server I get much higher FPS?

So far, Ive tried (without success):
- defragging my disk
- lowering game graphics
- custom high FPS executable config
- stopping all programs before running the game
- using a game booster
- setting high FPS launch options
- verifying the integrity of game cache
- updating my drivers

My specs: http://oi44.tinypic.com/25qxkxj.jpg
*Additional information: I do not own CS:S, but I have downloaded the necessary texture files and added it to the addons folders in the Gmod game files.

If you know any possible solutions, your help would be greatly appreciated. Thanks.
< >
Showing 1-15 of 41 comments
Agent218 Jan 10, 2014 @ 3:34pm 
With no problem i get 300 at alltime
Dakuwan Jan 11, 2014 @ 4:36pm 
what Hz is your TV or Monitor? Thing of it is, Your Monitor/TV can only display images so fast regardless of how fast the game is providing new images to the device.

Do you have V-Sync enabled? If so your framerate will probably lock at your monitor/TV refresh rate. which is usually 60fps.

i have seen Gmod freakout when i change graphic options while in "In game" and give me a frame rate that went into the 300's.

In conclusion 200fps is just as bad as 25 if its not the refresh rate of your TV/monitor. you can notice the lag in frames especially when things are moving side to side( scroll when playing from left to right at steady pace, the chop is noticable).
Queen Lisabear Jan 11, 2014 @ 5:31pm 
Hi, my refresh rate is 60 Hz, and vsync is off. While in spectator mode though, the game has no "choppiness" whatsoever.
Dakuwan Jan 11, 2014 @ 11:28pm 
alright, so for you to get the best frame rate at all times...
Enable V-sync
And that will get you 60 frames each second(if your comp IS NOT lagging from the rendering work, if it does lag it usually bumps it down to 30 Fps, or lower).



if im not explaining it well enough try this...

if every hour you decide to throw a ball over your fance to the next yard and your buddy catchs it, every min, for 60 mins. If you record the catchers yard every 1 min, you will see the ball being caught 60 times perfectly (Thats like V sync ON)

V sync off would be you showing up 200 times an hour and throwing the ball, meanwhile your buddy is still only ready to catch every 1 min

So if someone was to watch the video of all this with it recording only every one min at the catchers house, the video would not have the catcher catching a ball every min( Sometimes the ball would be to early, sometimes the ball would be thrown to late. Thats what causes the chop).

So, no matter how many balls are thrown, if the catcher isnt there to catch it then it doesnt really matter does it? The catcher being your display, the thrower being you FPS, and each hour being one second in game.


*WHEW*

If your still not getting 30fps or 60fps when v-sync enabled, AND you got all your graphics(especially Mu;ti Sample Anti Aliasing) toned down, then its time for a new Graphics Card, hell a new comp.

Now if your really interested in how your GPU(Graphics Processing Uint(graphics card)) is handling the graphical load, go get GPU-Z free program to monitor your GPU. if you load is at or near 100% then you can expect to have low frames even with V-sync.

OK IM DONE I SWEAR
Queen Lisabear Jan 12, 2014 @ 2:09pm 
Thanks for the detailed response. You are right abou tthe new GPU and PC of course. I've had this PC for around 4 - 5 years, and the GPU for 2 years. I was wondering, though, if you know why I get substantially higher FPS on one certain server? It doesn't seem to be different from any other servers I've been to, but I can get 60 FPS on it.
Queen Lisabear Jan 12, 2014 @ 4:24pm 
Update: I just tried various other game modes. It appears that the only problematic one is Murder. I get enough FPS in other game modes.
OMG I THOUGHT I WAS THE ONLY ONE HAVING THIS PROBLEM.....................
Rockn Roll Glue Apr 10, 2014 @ 2:36am 
Before you join any game, this this in console: cl_forcepreload 1
Not sure if it's cl_forcepreload or cl_preload. Try both.
Arrick :3 Jul 2, 2014 @ 7:40pm 
I get like 20 fps at the most in gmod but WAAAY better in beefier games like Watch_dogs or Gta4, Dead Space, etc. I have no idea why, someone please help

heres my specs:

Model: Asus Q550LF
CPU: Intel(R) Core(TM) i7-4500U CPU @ 1.80GHz (4 CPUs), ~2.4GHz
GPU: NVIDIA GeForce GT 745M
OS: Windows 8 64-bit
RAM: 8 gigs (8192MB RAM)
Screen: 1920 x 1080 pixels
Rockn Roll Glue Jul 3, 2014 @ 11:38am 
I was not able to find much info on the graphics card you have, but i would assume it's either because of heating(which would be most likely), or it's because of the general perfomance of your GPU. Try to download HWmonitor. If your graphics card has a temperature around 75-80 Celcius then you should try to cool your computer somehow.
While you're at it try what i recommended in the previous message on this topic.
Global Jul 3, 2014 @ 11:50am 
Murder creates halos. Halos on loot.
Halos in GMod are VERY UNOPTIMIZED.
I'd try your best to stay away from them. I think there's a console command to disable halos in murder, but I forgot...
Try typing in console
"find halo"
If you see any command related to murder and halos, type in 0 for it's field or something like it.
Last edited by Global; Jul 3, 2014 @ 11:51am
Sparhawk Aug 18, 2014 @ 12:30am 
Originally posted by SerbianAgent218:
With no problem i get 300 at alltime:angrytiger:
You wish.
Sikobae Mar 20, 2015 @ 1:10pm 
Because GMod will only ever use one core, regardless of your setting. Thanks Garry.
[BA] Slashflex May 7, 2015 @ 3:00pm 
I can only suggest before you spend money on a new graphics card, maybe see if it's your drivers?
dragothai Jul 1, 2015 @ 11:18am 
Originally posted by ID_8CAF:
Update: I just tried various other game modes. It appears that the only problematic one is Murder. I get enough FPS in other game modes.
as the murderer there are a couple console commands that help to raise fps mu_halo_knife 0
mu_footstep_maxlifetime 0 the footsteps one wil get rid of footsteps so you can set it to 5 or 10 (by default it's 30)
< >
Showing 1-15 of 41 comments
Per page: 15 30 50

Date Posted: Jan 10, 2014 @ 3:12pm
Posts: 41