Portal

Portal

查看统计:
Portal > 综合讨论 > 主题详情
BrandeX 2013年8月24日上午3:09
Game Running in Directx 8?
http://steamcommunity.com/sharedfiles/filedetails/?id=172314924

In the options, the game is set to Directx 8 and can not be changed. The store page seems to indicate this game is DX9 capable. It's Similar engine to other HL2 era games right?
I can force it on with -dxlevel 90 and it unlocks that last few video options, but it's weird that the default is DX8.

There is a post from someone else on this board saying a bunch of game FX are not as he remembers after reinstall. Perhaps he had it set in DX8 by default too.
最后由 BrandeX 编辑于; 2013年8月24日上午3:14
< >
正在显示第 1 - 9 条,共 9 条留言
Richard Spectre 2013年8月26日上午2:25 
I have Intel HD3000 and I get the same on the latest drivers.
mat_dxlevel 95 works fine for me, but I agree that it's a weird way to fix the game for beginners.

Also, this DX8 bug appears in Half-Life 2 demo.
最后由 Richard Spectre 编辑于; 2013年8月26日上午2:26
BrandeX 2013年8月26日上午5:11 
One thing that is annoying about using the command line option, is that you have to set your video options every time you load the game.
senseidongen 2013年8月27日上午7:42 
is there much visual benefit to enabling DX9 as described above? I'm running it maxed out on my laptop currently so should be room to push things higher
BrandeX 2013年8月27日下午7:23 
Yes, some graphic options are unavailable in the menu when in DX8 mode.
Wolfgam 2013年11月12日上午1:11 
put in set launch options "-dxlevel 80" for directx 8 and "-dxlevel 90" for directx 9
Snowman TSS 2014年3月17日下午3:27 
I solved the issues by adding the following to the launch options in Steam:

-novid -dxlevel 90 -mat_dxlevel 95 -w 2560 -h 1440 -refresh 60 +mat_forceaniso "16" +r_waterforcereflectentities "1" +mat_picmip "0" +mat_antialias "8" +mat_aaquality "2" +r_shadowrendertotexture "1" +r_rootlod "0" +mat_reducefillrate "0" +pp_bloom "1" +mat_queue_mode "2"

NOTE! Make sure your max resolution is set, and not the one I used.
Also note that some of the settings SEEM to be not set in the game menu, but they ARE active.
最后由 Snowman TSS 编辑于; 2014年3月17日下午7:08
nuh1 2014年3月17日下午5:45 
引用自 Snowman
I solved the issues by adding the following to the launch options in Steam:

-novid -dxlevel 90 mat_dxlevel 95 -w 2560 -h 1440 -refresh 60 +mat_forceaniso "16" +r_waterforcereflectentities "1" +mat_picmip "0" +mat_antialias "8" +mat_aaquality "2" +r_shadowrendertotexture "1" +r_rootlod "0" +mat_reducefillrate "0" +pp_bloom "1" +mat_queue_mode "2"

NOTE! Make sure your max resolution is set, and not the one I used.
Also note that some of the settings SEEM to be not set in the game menu, but they ARE active.

Holy crap lots of start up commands, lol.
You can generally just get away with starting the game up once with "-dxlevel 90" or "+mat_level 92" then just taking it out afterwards so you can save your video settings without it defaulting back. If you leave it in every load it will keep resetting your in-game video settings. Don't wory, once you force the game back into dx9 at least once, it should stay that way; unless valve decides to mess it up through a random update again.

Yeah, one of the updates awhile back just randomly defaulted everyone's games back to directx8 for some reason. Man those dx8 portals are ugly and flat.
Snowman TSS 2014年3月17日下午7:06 
yeah well I tried that with adding just the "-dxlevel 90" once...
When I removed it again it reverted to DX8 mode :(
That's why I made a command line that did it all EVERY time :D
最后由 Snowman TSS 编辑于; 2014年3月17日下午7:07
引用自 Snowman
I solved the issues by adding the following to the launch options in Steam:

-novid -dxlevel 90 -mat_dxlevel 95 -w 2560 -h 1440 -refresh 60 +mat_forceaniso "16" +r_waterforcereflectentities "1" +mat_picmip "0" +mat_antialias "8" +mat_aaquality "2" +r_shadowrendertotexture "1" +r_rootlod "0" +mat_reducefillrate "0" +pp_bloom "1" +mat_queue_mode "2"

NOTE! Make sure your max resolution is set, and not the one I used.
Also note that some of the settings SEEM to be not set in the game menu, but they ARE active.
Just run with
+mat_dxlevel 95
and it won't reset your video settigs every time.

For future reference
-mat_dxlevel 95
does nothing, console commads have to be preceded with +.

Additionally, -dxlevel 90 sets the same thing as +mat_dxlevel 90, so you would want to put -dxlevel 95. The difference between the two is the -dxlevel sets the configuration based on presets specified in dxconfig.cfg, whereas +mat_dxlevel 95 sets that console command first thing after the game starts up.
< >
正在显示第 1 - 9 条,共 9 条留言
每页显示数: 15 30 50

Portal > 综合讨论 > 主题详情
发帖日期: 2013年8月24日上午3:09
帖子数: 9