Portal > 一般的な話題 > トピックの詳細
BrandeX 2013年8月24日 3時09分
Game Running in Directx 8?
http://steamcommunity.com/sharedfiles/filedetails/?id=172314924

In the options, the game is set to Directx 8 and can not be changed. The store page seems to indicate this game is DX9 capable. It's Similar engine to other HL2 era games right?
I can force it on with -dxlevel 90 and it unlocks that last few video options, but it's weird that the default is DX8.

There is a post from someone else on this board saying a bunch of game FX are not as he remembers after reinstall. Perhaps he had it set in DX8 by default too.
最近の変更はBrandeXが行いました; 2013年8月24日 3時14分
1-8 / 8 のコメントを表示
< >
Richard Spectre 2013年8月26日 2時25分 
I have Intel HD3000 and I get the same on the latest drivers.
mat_dxlevel 95 works fine for me, but I agree that it's a weird way to fix the game for beginners.

Also, this DX8 bug appears in Half-Life 2 demo.
最近の変更はRichard Spectreが行いました; 2013年8月26日 2時26分
BrandeX 2013年8月26日 5時11分 
One thing that is annoying about using the command line option, is that you have to set your video options every time you load the game.
senseidongen 2013年8月27日 7時42分 
is there much visual benefit to enabling DX9 as described above? I'm running it maxed out on my laptop currently so should be room to push things higher
BrandeX 2013年8月27日 19時23分 
Yes, some graphic options are unavailable in the menu when in DX8 mode.
Wolfgam 2013年11月12日 1時11分 
put in set launch options "-dxlevel 80" for directx 8 and "-dxlevel 90" for directx 9
Snowman 3月17日 15時27分 
I solved the issues by adding the following to the launch options in Steam:

-novid -dxlevel 90 -mat_dxlevel 95 -w 2560 -h 1440 -refresh 60 +mat_forceaniso "16" +r_waterforcereflectentities "1" +mat_picmip "0" +mat_antialias "8" +mat_aaquality "2" +r_shadowrendertotexture "1" +r_rootlod "0" +mat_reducefillrate "0" +pp_bloom "1" +mat_queue_mode "2"

NOTE! Make sure your max resolution is set, and not the one I used.
Also note that some of the settings SEEM to be not set in the game menu, but they ARE active.
最近の変更はSnowmanが行いました; 3月17日 19時08分
nuh1 3月17日 17時45分 
Snowman の投稿を引用:
I solved the issues by adding the following to the launch options in Steam:

-novid -dxlevel 90 mat_dxlevel 95 -w 2560 -h 1440 -refresh 60 +mat_forceaniso "16" +r_waterforcereflectentities "1" +mat_picmip "0" +mat_antialias "8" +mat_aaquality "2" +r_shadowrendertotexture "1" +r_rootlod "0" +mat_reducefillrate "0" +pp_bloom "1" +mat_queue_mode "2"

NOTE! Make sure your max resolution is set, and not the one I used.
Also note that some of the settings SEEM to be not set in the game menu, but they ARE active.

Holy crap lots of start up commands, lol.
You can generally just get away with starting the game up once with "-dxlevel 90" or "+mat_level 92" then just taking it out afterwards so you can save your video settings without it defaulting back. If you leave it in every load it will keep resetting your in-game video settings. Don't wory, once you force the game back into dx9 at least once, it should stay that way; unless valve decides to mess it up through a random update again.

Yeah, one of the updates awhile back just randomly defaulted everyone's games back to directx8 for some reason. Man those dx8 portals are ugly and flat.
Snowman 3月17日 19時06分 
yeah well I tried that with adding just the "-dxlevel 90" once...
When I removed it again it reverted to DX8 mode :(
That's why I made a command line that did it all EVERY time :D
最近の変更はSnowmanが行いました; 3月17日 19時07分
1-8 / 8 のコメントを表示
< >
ページ毎: 15 30 50
投稿日: 2013年8月24日 3時09分
投稿数: 8