Portal > 一般的な話題 > トピックの詳細
smaug42 2013年6月27日 9時53分
Black screen when starting Portal (or any HL2 game) on Linux
I've recently started having probs with Portal, HL2 etc. On launch, all I get is a black screen. I've seen loads of posts about this issue from a couple of months ago, and solutions then seem to stem back to video drivers.

System config:
---------------------
openSUSE 12.3 64 bit with KDE4.10 with OpenGL compositing (not XRender)
Kernel = 3.7.10-1.16-desktop
Video = nvidia 660Ti, using proprietary drivers version 319.32 - verified that the drivers are in use, and Nouveau is blacklisted/not running

Other OpenGL based games launch fine, and Portal/HL2 was working 100% up until recently.

I have completely removed all Steam files,config files, and reinstalled from scratch with no change in results.

I've created a brand new user and started Steam under the new user with no change in results.

So... now what? Any suggestions?
1-6 / 6 のコメントを表示
< >
smaug42 2013年6月30日 9時48分 
Well... I guess I give up on Portal. It used to work perfect... now Portal (and HL2) are the only Linux games that refuse to work. Sucks... Portal is one of my favorite games. Sigh.
最近の変更はsmaug42が行いました; 2013年6月30日 9時49分
trussell 2013年8月4日 8時35分 
Don't give up! I too have this issue with OpenSUSE. It was working fine last week and it suddenly stopped working. I am going to try and trouble shoot this. I will report back here. :)
trussell 2013年8月4日 8時57分 
I found a fix!

1. Disable Steam In game community
2. Exit out of steam and reboot your computer
3. ...
4. Profit!!!

Link: http://steamcommunity.com/app/221410/discussions/0/864971287514339482/
最近の変更はtrussellが行いました; 2013年8月4日 8時58分
F'lar 2013年8月5日 23時15分 
Firstly, most Steam games are not entirely bug-free yet on linux. That said, instead of using an NVidia proprietary driver, SWITCH BACK TO NOUVEAU. Yes. You heard me. In my experience using Steam on linux, the games have not been compatible with my NVidia graphics card driver and have generated many errors and complete disasterous-quality rendering (due to those errors). Keep in mind that it's not NVidia's fault, but rather that of those porting a pre-existing game designed for a different operating system onto linux.
RaidSix 2013年9月18日 19時31分 
Try install this library in 32-bit (and 64-bit) mode: libtxc_dxtn
Worked for me!
maxwell 4月18日 2時26分 
RaidSix の投稿を引用:
Try install this library in 32-bit (and 64-bit) mode: libtxc_dxtn
Thanks! Worked fine for me too
1-6 / 6 のコメントを表示
< >
ページ毎: 15 30 50