Portal > Általános témák > Téma részletei
Solakka Silakka [FIN] 2013. máj. 3. @ de. 2:38
Portal Linux experiences
My experiences: working somewhat, but sometimes gets lagspikes and brief input lags. But when it works, i get a lot higher FPS than in Windows. Anyway, thanks Valve ^_^
115/199 megjegyzés mutatása
< >
Solakka Silakka [FIN] 2013. máj. 3. @ de. 2:39 
Note: reducing shader and shadow quality seems to make input lag spikes more rare
Solakka Silakka [FIN] 2013. máj. 3. @ de. 2:42 
And PC specs: AMD E-450, AMD Radeon HD 6320, 8 gigs of RAM, Ubuntu 12.04, newest AMD drivers (yes, i know that my PC sucks...)
eaglemmoomin 2013. máj. 3. @ de. 3:24 
Pretty good for a beta I think. I also have some the occassional input lag and there was terrible tearing before enabling v-sync. Editing the video settings does cause a noticable pause and um 'buzzing' noise. The game works with a wired 360 pad and you can edit buttons, sensitivity and the like. Not sure if the lag is the controller (Portal 2 on my much more powerful Windows box has a less sensitive response but no lag) or my AMD HD7770 and it's drivers. I'm running a C2D 8400, 3GB, Ubuntu 13.04 64 bit, Latest released Catalyst drivers. I have set all graphical settings to high and 8xAA and 8xAF to see how it copes and baring the occasional drop it's very playable. However the game is turning on the pads rumble pack on after getting the portal gun and then not switching it back off!
Archimedes_Stench. [Linux] 2013. máj. 3. @ de. 3:27 
Lucky. For me it loads, runs a few moments then crashes out to Desktop. :(
Solakka Silakka [FIN] 2013. máj. 3. @ de. 3:49 
T2|Archimedes_Stench. eredeti hozzászólása:
Lucky. For me it loads, runs a few moments then crashes out to Desktop. :(
It crashed for me too when i got to the second test chamber.
Archimedes_Stench. [Linux] 2013. máj. 3. @ de. 3:58 
I didn't make it even that far, for me it crashed out after going through the first Portal. :(
forever_alone 2013. máj. 3. @ de. 4:10 
Autosave cause game crash for me.
I can play with sv_autosave 0.
Except that everything is fine.
Djhg2K 2013. máj. 3. @ de. 4:17 
I started a new game and finished it in a couple of hours, messing around and trying to find any bugs. Works almost perfectly for me, with a few exceptions:


*Input lag as mentioned by others, only appeared once for me (using a bluetooth keyboard).

*On the final level there was a brief moment of flickering horizontal black bars, appeared twice with a few seconds interval. Never appeared again and I'm playing without vsync.

*Closed captions/subttles doesn't work at all.

*During the final credits it appears that there was a notification box in the lower right corner which in turn caused Portal to hang for a couple of seconds and then continue like normal. After quitting the game I also realized Steam had crashed. I have no idea from which application the notification came from since everything uses these little boxes nowadays, but the only ones I can think of with this capability that I had running was Steam and Opera (though Opera should have been completely idle at the time). Probably unrelated to Portal itself but on the off chance it is I just wanted to mention it.


System specs (I know not all is relevant but just to be safe):
Xen hypervisor 4.1.2 (Debian Sid x86_64 as dom0)
Ubuntu 12.04 i686
Intel Core i7-2600 (6 cores assigned and pinned)
8GB RAM (memory=8000 in Xen config)
ASUS Radeon HD 7950 (no boost)
100GB HDD
ASMedia ASM1042 XHCI Controller (USB 3)
Creative SoundBlaster X-Fi HD USB
Razer Lachesis 5600dpi
Generic cheap CSR based bluetooth dongle
Microsoft Bluetooth Keyboard 6000
(Everything else is generic Xen gardware)


Overall I'd say aside from the subtitles bug I would barely even notice it was in Beta.
Vortex (Combaticon) 2013. máj. 3. @ de. 4:23 
I only had two catastrophic in-game crashes--can't remember which chambers but both happened immediately after entering a portal in two different test chambers. Otherwise, I've mostly been noticing a plethora of graphical glitches (mainly transparency/opacity problems), the Still Alive screen seems out-of-scale (takes up about three quarters of the screen) and I also noticed that the gamma setting didn't do anything. I didn't notice any input lag here and it played great. Using an ASUS K53E with the built-in Intel video card (Intel Open Source Technology Center Mesa DRI Intel(R) Sandybridge Mobile x86/MMX/SSE2) running Kubuntu 12.04.2 LTS (64 bit).
Tuxle 2013. máj. 3. @ de. 4:36 
I noticed lags when something happens the first time (like opening portals, open a dor, see a touret, ...)

I' missing the bonus maps, too. :-(

Apart from that: Cool! *g*

System: Gentoo x64, i7 M 620, NVS 3100
UR|wRÅR 2013. máj. 3. @ de. 5:05 
For some reason it cannot sync the saves with the cloud on the first launch
eaglemmoomin 2013. máj. 3. @ de. 5:31 
Managed to get a pretty serious crash that killed Portal and then would'nt allow me to restart without rebooting the machine. Unfortunately I hadn't run steam in a terminal so have no clue what caused it. It's not doing it now when I try to repeat. Though I still get the occasional constant rumbling from the joypad when transitioning from one room to the next, how would you debug that?
predator8bit 2013. máj. 3. @ de. 5:34 
The shiny stuff (like portals) are visible through walls. And sometimes the textures are flickering. Kubuntu 13.04, on a lenovo laptop with intel graphics.
Legutóbb szerkesztette: predator8bit; 2013. máj. 3. @ de. 5:35
ministropepon[ES] 2013. máj. 3. @ de. 6:11 
Portal in Linux Is only available in English? i can play in spanish only in Windows?
instabilis 2013. máj. 3. @ de. 6:14 
ministropepon eredeti hozzászólása:
Portal in Linux Is only available in English? i can play in spanish only in Windows?
Do you not get the Spanish and Russian options in properties?
115/199 megjegyzés mutatása
< >
Laponként: 15 30 50
Küldés ideje: 2013. máj. 3. @ de. 2:38
Hozzászólások: 199