Portal > Algemene discussies > Details van topic
Saki 16 nov 2013 om 2:07nm
Portal says DirectX of GPU is v8.0 (HD6950/Win8.1)
Hey!

So I just ran Portal, because I wanted to play some, I haven't played it since 2 years and it is still my favourite SP game.

Now, for some reason, Portal in video settings says, my GPU DX is 8.0, which is totally bullcrap. I have AMD Radeon HD6950 1GB, DX11 Card, and I have Win8.1, with DX11.2 actually. Every other game states I have DX11.2, haven't tried other Source 2007 engine games.

How to fix this?

BTW I have newest Catalyst 13.11 beta 9.2 driver, because I play BF4 and it requires the newest beta drivers.
1-8 van 8 reacties weergegeven
< >
nuh1 18 nov 2013 om 2:46vm 
Try adding -dxlevel 90 to your launch options to force it into directx 9. Don't forget to remove it afterwards or else your settings won't save.
[PTH]Sapiens 18 nov 2013 om 5:56nm 
I recall having issues using the -dxlevel with Half-Life 2 (had the same type of DirectX auto-detection issue). You might want to try +mat_dxlevel 95 instead.
ÐÜÐĘŞåÜ©Ę™ 22 nov 2013 om 10:00nm 
For what ever reason,Portals textures have been "dumbed down" with recent updates.You can put whatever you want in launch options,and it may even say dx level 9 or whatever,but it won't change the way it looks.Shaders are dumbed down also.I have no idea what Valve did(brute forcing dx 8??lol).
Star Fire 24 nov 2013 om 1:17vm 
Origineel geplaatst door ÐÜÐĘŞåÜ©Ę™:
For what ever reason,Portals textures have been "dumbed down" with recent updates.You can put whatever you want in launch options,and it may even say dx level 9 or whatever,but it won't change the way it looks.Shaders are dumbed down also.I have no idea what Valve did(brute forcing dx 8??lol).
maybe there doing it for people with slow computers? but all around a better way would of been to have an opion to turn on DX 8 Mode for slower computers just saying
Abradox 16 dec 2013 om 4:36vm 
Have same problem on win7 x64. (AMD Phenom II X6 1035T, GeForce GTX 560 1gb, 8gb RAM). In win7 x32 it is normal.
|UNiT| DayOfTheSheep 19 dec 2013 om 4:29nm 
GTX 670 same problem. Sick of having to go through and redo all of my settings every time a crappy update is applied.

Worst is the new source games like Portal 2, L4D2 etc.
When the settings reset after an update and I have to redo all the settings, but with these games I have to click ok on a ♥♥♥♥n popup for each setting I want to make a change.
Laatst bewerkt door |UNiT| DayOfTheSheep; 19 dec 2013 om 4:30nm
Virulent 21 dec 2013 om 2:32nm 
I noticed this too, -autoconfig sets everything to DX 8.0 as instead of 9.0+ -dxlevel 95 fixes everything. I just tested -autoconfig on HL2 and it doesn't seem to mess around with the dxlevel.
|UNiT| DayOfTheSheep 21 dec 2013 om 3:39nm 
Origineel geplaatst door IBI Agent Blowfish. 55129156182:
Origineel geplaatst door ÐÜÐĘŞåÜ©Ę™:
For what ever reason,Portals textures have been "dumbed down" with recent updates.You can put whatever you want in launch options,and it may even say dx level 9 or whatever,but it won't change the way it looks.Shaders are dumbed down also.I have no idea what Valve did(brute forcing dx 8??lol).
maybe there doing it for people with slow computers? but all around a better way would of been to have an opion to turn on DX 8 Mode for slower computers just saying

From 2003.
1-8 van 8 reacties weergegeven
< >
Per pagina: 15 30 50
Geplaatst op: 16 nov 2013 om 2:07nm
Aantal berichten: 8