Portal > Γενικές συζητήσεις > Λεπτομέρειες θέματος
Alexander 28 Φεβ @ 8:27πμ
Portal Graphics Issue
I have Portal (Portal 1), on my computer with Windows 8.1, and it has the most ridiculous graphics I have ever seen. But on my dad's iMac, it works completely fine. The portals on my computer are like rings with very little detail, but on the iMac, it looks like those in Portal 2. And the windows of the observation rooms are like they are in Portal 2 on the iMac, but not on my computer. I have set the graphics on my computer as high as I could, but that doesn't work, either. And on the iMac there's radios around every single test chamber, and they have a red light on the front, and they turn green at a specific point of the test chamber. But none of this is on my computer. Can somebody help? Thanks! :D
Εμφάνιση 1-8 από 8 σχόλια
< >
nuh1 28 Φεβ @ 10:43πμ 
The low detail portals are from the game defaulting back to directx 8. Add "-dxlevel 90" to your launch options to force it back into directx 9. Just remember to take it out of launch options once you've loaded the game up with it once, or else your video settings won't save and keep going back to default.
Alexander 28 Φεβ @ 12:22μμ 
I'm sorry, but it doesn't work. Is there something else I can do? By the way, thank you for the advice. :)
floobadoo99 28 Φεβ @ 6:50μμ 
I just fixed this recently, but i don't know any other solution... :c i feel your pain, i had my portals like that for months of having the game until a few weeks ago :/
nuh1 28 Φεβ @ 6:51μμ 
Are you sure you are adding "-dxlevel 90" without quotes in the launch options? As far as I know, the directx 8 thing is the most common issue because an update was randomly defaulting everyones client back to it. And about the radios not being in your chambers, they were added in certain updates, maybe try verifying the games cache and see if it downloads new files or updates.
Τελευταία επεξεργασία από nuh1; 28 Φεβ @ 6:52μμ
Alexander 3 Μαρ @ 8:26πμ 
The problem about the radios are fixed, but the problem about the portals are still there. But still, thank you guys for the advice! :D
chriskringel 6 Μαρ @ 12:54πμ 
On the iMac the game uses OpenGL. On Windows it uses DirectX. So there seems to be something wrong with your DirectX version, or: its setting.

Right-Click on Portal in your library, you will see something like "launch options". Add the following:
+mat_dxlevel 92 (without " " should do just fine, and not "-dxlevel" but just +mat_dxlevel 92 // reference: https://developer.valvesoftware.com/wiki/Mat_dxlevel -- this varies from different version of the source engine.)

You can check it during the game via the console (see keybindings and check in "advanced" tab of keybindings if developer console is allowed to be activated) with simply typing: mat_dxlevel and ENTER. It should show you = 92. you can also type: help mat_dxlevel this will show you all dxlevels supported by the source engine in the game you play. Reference: http://www.tweakguides.com/HL2_8.html other example via regedit here: http://www.facepunch.com/threads/showthread.php?t=899398

Hope that helps you!

PS: After making the changes and during gameplay check your video settings *once*. Changing the mat_dxlevel can lead to that your anti-aliasing and other video settings could have been reset. Then you have to adjust them to your preference of quality again - just once, after it works.
Τελευταία επεξεργασία από chriskringel; 6 Μαρ @ 12:56πμ
Alexander 6 Μαρ @ 10:52μμ 
I'll try that and see what happens. Thank you for the advice! :D
Alexander 6 Μαρ @ 11:01μμ 
That fixed the entire problem!! Thank you all so much!! YAAAY!! :D
Εμφάνιση 1-8 από 8 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 28 Φεβ @ 8:27πμ
Αναρτήσεις: 8