Portal > General Discussions > Topic Details
can someone help me?
i'm on a linux pc and i just downloaded portal, but everything appears dark and textureless, can someone help?
Showing 1-2 of 2 comments
< >
I had the same issue, and it can be a number of things. First, launch Steam from the commandline so you get stdout/stderr output. Start the game, see if you can get to the point that you're having problems, and then quit. You may need to switch to a text console for this, or use an ssh login. This should give you some initial indication about what's going wrong.

For me, I had to do a few things before the game would work. I had to install support for S3TC (http://dri.freedesktop.org/wiki/S3TC/) via libtxc_dxtn. Then, I needed to configure DRI to always enable S3TC, as somehow Portal isn't able to determine that my video card is capable of it (I just finished the game, so it's definitely capable). I did this using driconf, which wrote a .drirc in my home directory. Here's what's in that file:

<driconf>
<device screen="0" driver="i965">
<application name="Default">
<option name="force_s3tc_enable" value="true" />
<option name="no_rast" value="false" />
<option name="always_flush_batch" value="false" />
<option name="always_flush_cache" value="false" />
<option name="shader_precompile" value="true" />
<option name="hiz" value="true" />
<option name="clamp_max_samples" value="-1" />
<option name="bo_reuse" value="1" />
<option name="force_glsl_extensions_warn" value="false" />
<option name="disable_throttling" value="false" />
<option name="disable_glsl_line_continuations" value="false" />
<option name="disable_blend_func_extended" value="false" />
<option name="vblank_mode" value="3" />
<option name="disable_derivative_optimization" value="false" />
</application>
</device>
</driconf>

You may need to tweak the other values, but the force_s3tc_enable was the important part for me. Hope this helps!
thanks! i'll go try it now.
Showing 1-2 of 2 comments
< >
Per page: 15 30 50