ArcaniA > General Discussions > Topic Details
moaddib Aug 24, 2013 @ 1:28pm
Solution (worked for me) for start up problems and bad performance
Hi,
I bought the game although I've already read about the issues with the start. I just can't resist any Gothic like game.
I had the start up problem, so I looked here and googled elsewhere.
That what I did and what worked for me (you may not need first step but I had to do it

My system: Win XP 32 SP3, 240 GT

1- I ran steam own verification (access through your game library). It found that I need an newer version of PhysX (PhysX.9.12.1031). Since I had problems with latest Nvidia drivers (>6.20) and I couldn't install them, I had an older PhysX driver, thus, I downloaded the needed one (If u have this issue, be certain to download the physx driver mentioned in the error message, even if it is not the latest).

2- This brought me to the second phase, but the game kept crashing. In some thread I found that some people could only run the game (different OS,s) after they have DEINSTALLED, an not only deactivated, their Antivir software (mostly Avast). So, I deinsatlled my Avira Antivir.
Game started :-).

3- The performance was ok but the game was slow and it shuttered. I found a solution in another forum: http://www.gamefaqs.com/boards/939672-arcania-gothic-4/57104961 and it worked for me: the game runs now absolutely ok even with my old system.

I hope this would help solving some of your issues.


Last edited by moaddib; Aug 24, 2013 @ 1:30pm