ArcaniA > 综合讨论 > 主题详情
Derko1 2013年8月19日下午12:58
Very bad performance with good system.
So I bought this game a WHILE ago and had given up trying to play it. Basically, when I get to the first island with the rain, I am hovering at around 22-27 fps the whole time... if I lower the settings to low, I get around 2-3 fps more and that's it. There's a lot of areas where I'm getting 80+ fps, but here, always below 30.

This week's sale reminded me that I wanted to play through it.

So, I've tried disabling crossfire, tried dozens of drivers over the years and nothing helps this game run better.

Any idea what the issue is or if it can be fixed? Anyone else have similar specs and have the game run fine/same as me for them?

My specs: http://www.overclock.net/lists/display/view/id/3943728

i7 3770k @ 4.8 Ghz ASRock z77 Extreme 6
2x HD7970s 3GB CF
16gb x G. Skill Ripjaws Z 9-11-10-28 DDR3 PC2133 OCZ
1x Samsung 840 Pro 256 GB
1x Vertex 3 120GB SSD
3x Caviar Blue 1.0TB WD10EZEX
1x Deskstar 1.5TB HDD
Corsair Fatal1ty 1000-Watt PSU
Corsair 800D case
Chrome Raystorm CPU block with Swiftair Komodo 7970 GPU blocks.
正在显示第 1 - 9 条,共 9 条留言
< >
Revelator 2013年8月20日上午9:09 
in my system works fine with a single 7970 and graphics maxed
Revelator 2013年8月20日上午9:10 
Core i7-2600;Asrock Z68Pro3;16-GB ddr3-1600;Sapphire Radeon 7970-3GB-D.B.;X-Fi eXtreme Music; Win 8 64 bit
Derko1 2013年8月20日下午12:07 
Thanks for the info. I actually had some crazy issues with the first 13.8 driver, so I'm gonna try b2 and see if it gets resolved.

But yea... I guess it's a very specific issue with Crossfire then. A buddy of mine has no issues with the game either.
Member0815 2013年8月23日下午11:08 
Try the realease hotfix. Jowood realeased an incomplete game with many issues and much fps drops. This patch should give you about 170% better performance.

This should help you:
Patch[www.chip.de]
Derko1 2013年8月24日上午3:34 
引用自 Member0815
Try the realease hotfix. Jowood realeased an incomplete game with many issues and much fps drops. This patch should give you about 170% better performance.

This should help you:
Patch[www.chip.de]

That patch is already applied to the steam version. I just tried it for the heck of it... and it makes the game ask me for my serial key, which the steam version does not have. Like I said though, the patch is already on the Steam version.
Member0815 2013年8月24日上午4:58 
Well this shouldn't be a problem. Just download the 3 remaining patches and install them. After that you can play it without the serial key.

IMPORTANT TO ALL! Don't start the game with steam. The laggs will be still there. Instead go to "C:\Program Files (x86)\Steam\SteamApps\common\Arcania Gothic 4" and look for "Arcania_original_bak.exe". Start the game with it and everything should be fine.

Have Fun with playing <3
Τhe Rolling Cheese Wheel 2013年9月11日上午9:27 
引用自 Member0815
Well this shouldn't be a problem. Just download the 3 remaining patches and install them. After that you can play it without the serial key.

IMPORTANT TO ALL! Don't start the game with steam. The laggs will be still there. Instead go to "C:\Program Files (x86)\Steam\SteamApps\common\Arcania Gothic 4" and look for "Arcania_original_bak.exe". Start the game with it and everything should be fine.

Have Fun with playing <3

What 3 patch? I only see 1.
Derko1 2013年9月11日下午3:51 
引用自 Member0815
Well this shouldn't be a problem. Just download the 3 remaining patches and install them. After that you can play it without the serial key.

IMPORTANT TO ALL! Don't start the game with steam. The laggs will be still there. Instead go to "C:\Program Files (x86)\Steam\SteamApps\common\Arcania Gothic 4" and look for "Arcania_original_bak.exe". Start the game with it and everything should be fine.

Have Fun with playing <3

What 3 patch? I only see 1.

Yea... I forgot to reply way back and there are no 3 patches.
正在显示第 1 - 9 条,共 9 条留言
< >
每页显示数: 15 30 50
发帖日期: 2013年8月19日下午12:58
帖子数: 9