Nerdy Pervy Nov 25, 2012 @ 2:31am
CD Key And Windows 7 64 Bit
With Windows 7 I had to enter my CD key every time even though I am running as an administrator. I found that in order to not have to reenter the CD key, you need to run steam in Window XP compatibility mode. I hope this helps.
Showing 1-15 of 16 comments
< >
Jamse Nov 27, 2012 @ 7:51am 
Thanks! was getting very annoying
Mike Dec 6, 2012 @ 9:39am 
You can turn the compatibilty mode off again, once it is activated :-)
Tarul Dec 17, 2012 @ 12:01pm 
Thank you very much arthurschamne!
rmjohnson144 Dec 17, 2012 @ 9:59pm 
Bummer, I tried setting steam to XP compatibility mode and it locks up completely. Same with vista compatibility mode.

Any other work arounds?
-=Mark=-
rmjohnson144 Dec 17, 2012 @ 10:08pm 
Sorry, I'm using Win8 Pro MCE x64, not win7.

I run in win7 compatibility mode and it still asks for key every time I run it.

Any clues?
-=Mark=-
sascha1096 /// being bad Dec 18, 2012 @ 9:08am 
Hey Guys
does the Game run on Win 7 x 64 Bit? I´ve got and i5 650 Processor and SF TOOD does not run.Thanks for Help.
reaveramori Dec 23, 2012 @ 9:16pm 
I am running win 7 64 bit ultimate, the processor and graphics card should not matter as long as your computer is not older than 5 years (give or take). I am running on 3yr old laptop with max settings and your system is definitely better. The only issue I have is the one described above, where you have to enter the key every time you play. No other issues besides that.
Last edited by reaveramori; Dec 23, 2012 @ 9:18pm
sascha1096 /// being bad Jan 4, 2013 @ 5:40am 
Ok i will hope that the game is working on my PC, because on my first system spellforce doesn´t run on any way.Can it be that the Dics was damaged ?
lsfwahahaha Jan 4, 2013 @ 11:11pm 
very useful,thank you very much
Hallwaxer Feb 3, 2013 @ 9:14am 
Originally posted by lsfwahahaha:
very useful,thank you very much
I agree with that person. I was about to post this question.
__ Mar 25, 2013 @ 6:30pm 
I am running Win 7 64-bit and when I click options the game crashes.
Cunin Mar 30, 2013 @ 11:43am 
Originally posted by __:
I am running Win 7 64-bit and when I click options the game crashes.
there's another thread for that
__ Apr 1, 2013 @ 10:30pm 
Great, what is the lilnk?
Warhawke Apr 4, 2013 @ 3:24pm 
Suggestion did not work for me. Still have to enter CD key each time. Any other suggestions?
Cunin Apr 5, 2013 @ 7:29am 
Try this:
1) Open regedit with administrative privileges
2) Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\SpellForce
3) In the right side of the window you should see 3 items, named CDKEY, CDKEY1 and CDKEY2. If you don't see them, create them by right clicking on that area and selecting New>String Value, and then correctly name them.
4) Double-click on the CDKEY one and insert the cdkey that Steam gives you, in uppercase and with the - symbols (so exactly as it's shown by Steam)
5) Now close regedit and try running the game.

I'm not sure if this works, as I didn't have that problem, but might be worth a try.
Showing 1-15 of 16 comments
< >
Per page: 15 30 50