j_goularte Jun 1, 2013 @ 1:05pm
CD Key Fix
In order to fix the CD Key provblem, which is extremely annoying I might add, you need to play the game as an administrator. In order to do this, you need to right click on the Steam icon on your desktop or from the start menu and click on Properties. Then, click Open File Location. This should open up another window, in which you will right click the Steam application and click on the compatibility tab. Check the "Run This Program As An Administrator" box and close the window. Return to the other window you have open AFTER YOU HAVE CLICKED ON Apply. Open up the folder SteamApps, then common, then SpellForce Platinum Edition. Right Click the SpellForce Platinum Edition application, select properties. Click on the compatibility tab. Check the "Run This Program As An Administrator" box and click apply. Now open up the game. If there is a warning box, just click close (this is just explaining they don't want you to play Steam games while Steam is on admin). Type in your code one last time and hit okay. Close the game and open it again, and VOILA!!! You can now play your game without having to type in the CD Key every time.

If you need help finding your CD Key...

In game, hold down shift and hit the tab key. you should be able to find the CD key through this menu.
Showing 1-7 of 7 comments
< >
j_goularte Jun 1, 2013 @ 1:09pm 
NOTE: While running in Admin, you won't be able to access Steam community while in the game. So in order to get your CD Key, you should write it down before attempting to run in Admin.
Maxson20 Jul 19, 2013 @ 8:33pm 
Thanks j_goularte. Most helpful.
j_goularte Jul 26, 2013 @ 3:23pm 
Anytime :) Hope you enjoy the game.
TotalAbyss Nov 10, 2013 @ 8:27pm 
This is very annoying can't we get a patch or something to fix this issue?
Alucard91 Nov 30, 2013 @ 9:21am 
i followed your instructions to the letter but it still asked for the key after i started it back up :/

*** worked fine second time round i have no idea why, works now thanks :) ***
Last edited by Alucard91; Nov 30, 2013 @ 9:27am
Assassin Jan 23 @ 11:33am 
will it stil work if I remove "run as administartor" later?
Hinsonator Jan 23 @ 2:01pm 
this only works once, after you reboot your PC you get a black screen (at least i did)
Showing 1-7 of 7 comments
< >
Per page: 15 30 50