SpellForce: Platinum Edition

SpellForce: Platinum Edition

Kurosawa0 Feb 24, 2013 @ 2:59am
Multiplayer Co-op Lan / Hamachi
Well, I got a really annoying problem. I wanted to play in Free Game Mode with a friend and we tried getting a game started, using Hamachi.
We can see each others games, but their status is marked with a red circle ingame and it is impossible to join ( The button for joining is grayed out ).
Think anyone of you knows how to fix that ? I mean, Firewall is off, we can see the games, chat using hamachi, we have the same gameversion, I can ping him. Actually, it should work or not ?
< >
Showing 1-1 of 1 comments
Kurosawa0 Feb 24, 2013 @ 7:49am 
Alright, looks like we did find a solution in a different forum.
I'll link and post it here right away.

You must have the Option "Behind Router" in the SF Option Menu On and you must open the following ports in your router config menu:

UDP 2302-2400 (DirectPlay device address default)
UDP 2801 (SpellForce Game)
TCP 3783 (Voice Chat Port)
UDP 3783 (Voice Chat Port alternative)
UDP 6073 (DirectPlay enumerations using DPNSVR)
UDP 6515 (Dplay UDP)
UDP 6500 (Query Port)
TCP 6667 (Gamespy Chat)
UDP 13139 (Custom UDP Pings)
UDP 27900 (Master Server UDP Heartbeat)
TCP 28900 (Master Server List Request)
TCP 29900 (GP Connection Manager)
TCP 29901 (GP Search Manager)

Btw: You must use the same version. So install at both Systems Patch 1.38.

If you create a Coop Game you must use the Coop LAN GameBrowser to join the game and if you create a PvP Game you must use the PvP LAN GameBrowser.


Last edited by Kurosawa0; Feb 24, 2013 @ 7:50am
< >
Showing 1-1 of 1 comments
Per page: 15 30 50

Date Posted: Feb 24, 2013 @ 2:59am
Posts: 1