s3heherr Dec 18, 2012 @ 7:03am
Crashes when saving or opening options - D3DD Error
Hi,
whenever I try to save a game or open the options, the game crashes. Displayed error: "D3DD invalid call (8083)".

System:
Windows 8 Pro 64 Bit
Ati Radeon 4200 / 5400 HD (mobility)
Athlon 2 2x 2,1 ghz

Windows XP Mode did not help.
I tried using another resolution (config.au), but it didn't help.

Has anyone an idea how to solve that problem?

thanks
Last edited by s3heherr; Dec 18, 2012 @ 8:08am
Showing 1-10 of 10 comments
< >
Revelator Dec 18, 2012 @ 7:08am 
some problem here.
you took our money. now make a patch.
Z4m4kr0n Dec 18, 2012 @ 9:24am 
Same problem here.
If u Fail do it Epic Dec 18, 2012 @ 11:26am 
i HAD the same problem just dont run the game from steam go in ur install directory and start the game with administrator privelegs. now savegame and options work for me ;) hope it will help u and sorry for my bad english ^^
s3heherr Dec 18, 2012 @ 12:24pm 
Thank you for your answer.
Unfortunately your solution has not worked with my pc.
In the meantime I also have installed the latest, a BETA, as well as an older ATI graphics driver. I even tried start the game with just the basic Windows drivers. Nothing helped.

Originally posted by Draroth:
i HAD the same problem just dont run the game from steam go in ur install directory and start the game with administrator privelegs. now savegame and options work for me ;) hope it will help u and sorry for my bad english ^^
ygarian Dec 28, 2012 @ 10:26am 
Similar problem here. Save works (Win7 Pro 64, up-to date catalyst driver for HD4890), but option crashes. Unless the program is started windowed (-window). Since I want to run it full-screen, the only way to change options is by leaving the game, restarting it windowed, making the change, then restarting it full-screen. Which sucks.
My old CD-version didn't have that problem, so it seems to be up to Steam to fix this.
Revelator Feb 17, 2013 @ 10:29am 
up fix this problem via steam.
__ Mar 25, 2013 @ 6:28pm 
I just purchased and installed the game. Entered the key, got to the main screen and clicked options, and game crashed with a message similar to: "Windows encountered a problem,.... blah blah ...."
Running Win7-64bit, MSI H55-S01, Two HD4870 in Crossfire Mode, latest Catalyst drivers, Intel Core i3 540 socket 1156, 6gb PC3-10700h.
Can anyone help? Looks like other users are having the same issues.
dzhemik Apr 24, 2013 @ 2:31pm 
I have the same problem with these crashes on save (with Win8/64, AMD Radeon HD 7570). Oddly, though, I didn't have it at first, and played about 8 hours (completely through the tutorial and first segment) with both escape (for quit; I kept clicking it by accident) and the option button working fine. After that, though, it seemed it crashed on both the esc and all attempts to save a game, which lost me the entire progress on the second segment.

HOWEVER, I think I figured it out. The only things I think I changed were the resolution, which I upped a couple of times as I was going (saving/loading since this can only be done at the main menu), and the compatibility settings -- I had set WinXP mode and Run as Admin at some point to avoid that stupid key request at every start. Changing the resolution back did not do the trick, but turning off WinXP compatibility mode DID... I was able to load and save a game, and I just confirmed that turning the resolution back up to max didn't change that. I kept Run as Admin on, and it didn't ask for a key.

Hope that might help others with this problem!
__ Apr 26, 2013 @ 11:04pm 
Thank you I will check that solution out. Thanks for posting about it.
ender_wiggin123 May 9, 2013 @ 5:00pm 
I had the same problem and when i turned compatibility mode off it worked fine again.
Showing 1-10 of 10 comments
< >
Per page: 15 30 50