quizaht Sep 20, 2013 @ 10:59pm
Still Broken?
Just bought the game. Created the config.ini file to get past the first directx error. Also re-pathed steam to get past the "can't find steam" error.... Only to get to another directx error when the game window finally launches. Any help, or is this just a game that no one should buy?
Showing 1-9 of 9 comments
< >
MobySlick Sep 20, 2013 @ 11:36pm 
Lots of people are playing, but sorry to hear you are having a problem. Mine crashed the first time I tried to change video res from default directly to 1280x960 (highest the game can do). But then changing it step by step one larger res at a time worked.
Spike Sep 21, 2013 @ 2:09am 
i am also not able to play this game on my win 8 notebook.. it will freeze after start.. bug game!
Sherlock Holmes Sep 21, 2013 @ 5:58am 
I'm trying everything to fix this game. I'll post here if i find something, and if someone discovers something please tell me!
Birdy Sep 25, 2013 @ 1:12pm 
it doesnt wor´`k, since last steam update .... it worked perfectly... . getting dx errors now
W8 64bit,
Landrick Sep 25, 2013 @ 10:22pm 
I get a message that says "Unable to initialize DirectX." when I try to launch the game.
Possible solutions to this problem include:

Make sure you have DirectX 9.0C or greater and that it is working properly.
Make sure you have the latest video drivers for your video card.
Try running Pirates! in Safe Mode (use the Pirates! - Safe Mode shortcut on the start menu).



^^This is from the official "Readme" (its in your steam folder) I did those things and it let me find the problem... unfortunately I can't remember what it was now :(. I will post back if i remember. See if that helps, and google away!

edit: maybe here? http://forums.steampowered.com/forums/showthread.php?t=922656
quizaht Sep 25, 2013 @ 11:43pm 
I'm unable to find an option to start Pirates in safe mode. I at first had the direct x error, then got past that by creating the config.ini file to match my 1980x1020 resolution. Then had the unable to find steam error, so I re-pathed steam (i forget how, but there's a forum post on it). Now I get a black window, and the spinning... "ship steering wheel?"... whatever it's called, for about 2 seconds before the program crashes and says "unable to initialize directx" again...

Relevant OS specs, win 7 - 64

Also, thanks to all the folks empathizing and trying to help so far :)
p88h Sep 26, 2013 @ 2:40am 
it seems to work perfectly for me (win7, nvidia gtx) - I didn't mess with config.ini though - why would one want to do that? the aspect of the game is 4x3 so you can just play in 1600x1200 with black bars?
Birdy Sep 26, 2013 @ 3:28am 
The problem aint't the black bars- "dx errors" and "unable to find steam" are.
The program works perfectly on win764bit with a nvidia card (laptop)
It worked on my PC win864bit with amd card - until the last steamclient update. THAT`s the problem.
PS: older dx versions are installed /older dx6,8,9 games work perfectly (just for info)
Birdy Sep 26, 2013 @ 3:30am 
new steamlient available since 23September13 - hope that it'll do the trick
Showing 1-9 of 9 comments
< >
Per page: 15 30 50