Drummer Dude Apr 21, 2013 @ 5:25pm
platform
it says this game wont play on my current platform, what does that mean
Showing 1-1 of 1 comments
< >
Rastrelly May 3, 2013 @ 9:02am 
Strange question. What operating system do you use? Civ III will run on any Windows from 98 up to 8 (i.e. 98, ME, 2000,XP, Vista, 7, 8), as far as I know. As for Mac and Linux - again, AFAIK - it just won't work. Wel, in case of Linux there is WINE.
Showing 1-1 of 1 comments
< >
Per page: 15 30 50
Date Posted: Apr 21, 2013 @ 5:25pm
Posts: 1