Fallout > General Discussions > Topic Details
MrBagglzz Feb 19, 2013 @ 5:54pm
Detailed explanation on how to fix the rainbow pixels and black eraseable screen. FO1/FO2
I'm not the brightest person when it comes to fixing these sort of problems with games and i have read the fourms on how to fix them except i need more details cause in the first second im trying to fix it im lost. i've tried the patchs and the manual installing of the games but i get really confused on how to do it. i don't want a refund cause im not that whiney and i enjoy fallout. If someone can please explain step by step on how to fix these two probloms in fallout 1 and two I'd be very greatful
Showing 1-15 of 55 comments
< >
Artemis Herdmann Feb 20, 2013 @ 2:13am 
You can shut down the explorer.exe with Ctrl+Alt+Suppr after launching the game. You will be able to play without any graphics problem. Hope it help.
ivangoldenhands Feb 20, 2013 @ 5:02am 
Sorry for my english first of all.
To fix graphic bugs you need change ddraw.ini file (C:\Program Files (x86)\Steam\steamapps\common\Fallout\ddraw.ini in my case).
Change next:
Mode=4 in [Graphics] section
and
TextureFilter=1
This should fix the problem.
MrBagglzz Feb 20, 2013 @ 8:36am 
i have done tried shutingt down the explorer.exe first day i played it work but then it went back to the glitch with the black screen. i've also tried changing the mod i never really noticed anything with it
MrBagglzz Feb 20, 2013 @ 11:38am 
i got it to work thank you, i was using the wrong fallout folder
ivangoldenhands Feb 20, 2013 @ 8:56pm 
Not at all.
compdoc Feb 21, 2013 @ 4:32am 
Originally posted by ivangoldenhands:
To fix graphic bugs you need change ddraw.ini file (C:\Program Files (x86)\Steam\steamapps\common\Fallout\ddraw.ini in my case).
Change next:
Mode=4 in [Graphics] section
and
TextureFilter=1
This should fix the problem.
Thanks for posting this fix. :)

I read through mountains of supposed "fixes" that included various patches and loads of configurating, etc, etc. However, simply changing Mode=4 amd TextureFilter=1 in the ddraw.ini file solved the problem in both Fallout 1 and Fallout 2, took only a few seconds.

Your advice saved a lot of time and trouble for both games, thanks again!
MrBagglzz Feb 21, 2013 @ 8:04am 
i know what you mean
Crimson Eagle Feb 21, 2013 @ 10:29am 
Originally posted by ivangoldenhands:
Sorry for my english first of all.
To fix graphic bugs you need change ddraw.ini file (C:\Program Files (x86)\Steam\steamapps\common\Fallout\ddraw.ini in my case).
Change next:
Mode=4 in [Graphics] section
and
TextureFilter=1
This should fix the problem.

Well, Mode=5 worked pretty good to me, Mode=4 actually crashed the game, at least with me.

And Mode=5 also solved something I was wondering, about setting the game to Windowed, Mode=5 is Windowed by default.
Last edited by Crimson Eagle; Feb 21, 2013 @ 10:30am
MrBagglzz Feb 21, 2013 @ 10:53am 
it works man
JooonyGooonza Feb 21, 2013 @ 12:19pm 
Originally posted by ivangoldenhands:
Sorry for my english first of all.
To fix graphic bugs you need change ddraw.ini file (C:\Program Files (x86)\Steam\steamapps\common\Fallout\ddraw.ini in my case).
Change next:
Mode=4 in [Graphics] section
and
TextureFilter=1
This should fix the problem.

Thanks for your help!
JooonyGooonza Feb 21, 2013 @ 12:20pm 
Originally posted by Insane:
[Main]
;Change to 1 if you want to use command line args to tell sfall to use another ini file.
UseCommandLine=0


;XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
[Speed]
;Set to 0 to disable everything in this section
Enable=1

;The speeds corrisponding to each slot in percent. (i.e. 100 is normal speed)
SpeedMulti0=50
SpeedMulti1=100
SpeedMulti2=150
SpeedMulti3=200
SpeedMulti4=300
SpeedMulti5=500
SpeedMulti6=1000
SpeedMulti7=100
SpeedMulti8=100
SpeedMulti9=100

;The initial speed at game startup
SpeedMultiInitial=100


;XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
(a)[Graphics]
;Set to 0 for 8 bit fullscreen
;Set to 1 for 8 bit windowed
;Set to 4 for dx9 fullscreen
;Set to 5 for dx9 windowed
;Mode 1 requires your desktop colour depth to be set to 32 bit
;Windowed modes incur a performance hit. (Modes 1 and 5 more so than mode 3)
;The 16 bit colour modes cause movies to display incorrect colours, and slows down fades
;dx9 modes cause some corruption of movies, but not as bad as 16 bit colour modes
;dx9 modes work with fallout 1, but results in movies being completely corrupted
(b) Mode=0

;Refresh the screen every x frames. Set to 0 to disable frameskipping.
;If you don't want frameskipping on initially, but may want to enable it later, set this to 1
;This has no effect in fullscreen mode or in dx9 modes
FrameSkip=0

;If using a dx9 mode, this changes the resolution
;The graphics are simply stretched to fit the new window; this does _not_ let you see more of the map
;If you want to use an upscaling filter other than the hardcoded once listed below, place a dx9 effect file called 'global.fx' in data\shaders
GraphicsWidth=800
GraphicsHeight=600

;If using a dx9 mode, this changes the settings of the global shader
;Set to 0 to disable, 1 to use only if screen res > 640x480, 2 to use if screen res != 640x480 or 3 to use always
GlobalShaderMode=1

;Set to something other than 0 to apply a software scaler in graphics modes 4 or 5
;0 - without scale filters
;1 - 2xSai
;2 - SuperEagle
;3 - Super2xSai
;4 - hq2x
;5 - AdvancedMame2x
ScaleFilter=0

;Set to 1 for a linear texture filter, or 0 to disable
(c)TextureFilter=0

;XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
[Input]
;Set to 0 to disable everything in this section
;This will also disable any input related script extender functions and the keyboard commands used to control other sections!
Enable=1

;Set to 1 to enable the mouse scroll wheel to scroll through your inventory
UseScrollWheel=1

;The mouse Z position is dividied by this modifier to calculate the number of inventory
;slots to scroll. My mouse moves 120 pixel in the z direction for one click of the mouse
;wheel, but this may vary depending on your mouse manufacturer and windows settings.
;Set to 0 to only ever scroll 1 click
ScrollMod=0

;Adjusts mouse sensitivity to some percentage of normal.
;Negative values are valid, if you want your mouse axis reversed for some reason
MouseSensitivity=80

;DX scancode of a key to press when the middle mouse button is clicked
;The default of 0x30 toggles between your two weapons
;Set to 0 to disable
MiddleMouse=0x30

;Set these to 1 if you want fallout to access the keyboard or mouse in background mode
BackgroundKeyboard=0
BackgroundMouse=0

;XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

;The modifier key you have to hold down to change any speed settings
;If set to 0 if you don't want to use a modifier key, or a DX scancode otherwise
;Set to -1 for either ctrl key, -2 for either alt key or -3 for either shift key
SpeedModKey=-1

;A key to press to toggle the speed tweak on or off
;Specify 0 if you don't want a toggle key, or a DX scancode otherwise
SpeedToggleKey=0x00

;The keys corrisponding to the 10 speed slots
;Set to 0 to disable a slot, otherwise specify the DX scancode of the key you want to use
SpeedKey0=0x52
SpeedKey1=0x4f
SpeedKey2=0x50
SpeedKey3=0x51
SpeedKey4=0x4b
SpeedKey5=0x4c
SpeedKey6=0x4d
SpeedKey7=0x00
SpeedKey8=0x00
SpeedKey9=0x00

;The modifier key you have to hold down to change any graphics settings
;Set to 0 if you don't want to use a modifier key, or a DX scancode otherwise
;Set to -1 for either ctrl key, -2 for either alt key or -3 for either shift key
GraphicsModKey=0

;Increase/decrease frame skip.
IncreaseFrameSkip=0x51
DecreaseFrameSkip=0x4f

;Toggle the global shader on or off
ToggleGlobalShader=0x52

;Changes the current scaleing and texture filters
CycleScaleFilter=0x53
ToggleScaleFilter=0x4f
ToggleTextureFilter=0x50



--------------------------------------------------------------------
what do i change? (b) and (c)


Hey, Insane

[Graphics]
;Set to 0 for 8 bit fullscreen
;Set to 1 for 8 bit windowed
;Set to 4 for dx9 fullscreen
;Set to 5 for dx9 windowed
;Mode 1 requires your desktop colour depth to be set to 32 bit
;Windowed modes incur a performance hit. (Modes 1 and 5 more so than mode 3)
;The 16 bit colour modes cause movies to display incorrect colours, and slows down fades
;dx9 modes cause some corruption of movies, but not as bad as 16 bit colour modes
;dx9 modes work with fallout 1, but results in movies being completely corrupted
Mode=0

Where it says,
Mode=0
Change 0 to 4

;Set to 1 for a linear texture filter, or 0 to disable
TextureFilter=0

Where it says
TextureFilter=0
Change 0 to 1

Hope that helped

The stone worth living under Feb 21, 2013 @ 1:01pm 
ivangoldenhands, thank you very much, helped a lot!
MrBagglzz Feb 21, 2013 @ 1:07pm 
is there a way to edit my gamesave to take away me radiation cause im screwed over by it?
Radical Dreamer Feb 22, 2013 @ 11:01pm 
Originally posted by ivangoldenhands:
Sorry for my english first of all.
To fix graphic bugs you need change ddraw.ini file (C:\Program Files (x86)\Steam\steamapps\common\Fallout\ddraw.ini in my case).
Change next:
Mode=4 in [Graphics] section
and
TextureFilter=1
This should fix the problem.

Thank you so much. This is what I'm looking for.
MrBagglzz Feb 23, 2013 @ 9:03am 
thats what happens.
Showing 1-15 of 55 comments
< >
Per page: 15 30 50
Date Posted: Feb 19, 2013 @ 5:54pm
Posts: 55