Fallout > General Discussions > Topic Details
VikingWolf1342 Jan 6 @ 9:43am
Rainbow colors?
Most of my screen it covered with glithcy rainbow colors any way to get rid of it?
Showing 1-15 of 15 comments
< >
✪PK24✪ Jan 17 @ 7:54pm 
I have the same problem I wish I could help you.
bumbletwat Jan 17 @ 9:13pm 
I have the same issue, it is caused because back in the 1990's(?) games rarely had missing textures because they were on disc, if a game did detect missing textures, it would put in a random color thinking no one would notice, thus creating the rainbow colors.
Timetravelling Jellyfish Jan 18 @ 11:19am 
There are solutions to this problem all over this forum. Check out some other threads.
VikingWolf1342 Jan 19 @ 4:48pm 
Ok thanks
Joe Core Feb 1 @ 9:28am 
link to this thread pls
GunSlinguz Feb 9 @ 5:38pm 
Its a complete shame why I have to manually fix this game to play on my computer. Im too lazy to fix this, so its a usless gift from a friend.
VonStreed Feb 15 @ 10:51pm 
Originally posted by GunSlinguz:
Its a complete shame why I have to manually fix this game to play on my computer. Im too lazy to fix this, so its a usless gift from a friend.

wow! it takes 90 seconds to fix. http://www.interplay.com/forums/viewtopic.php?f=12&t=889
DeepBlue1973 Feb 16 @ 2:55am 
Doesn't work for me, still got rainbow colors... :(
Gavener Feb 16 @ 6:32am 
i tried your link i seen no interplay folder for windows 7
VonStreed Feb 16 @ 6:07pm 
Originally posted by Gavener:
i tried your link i seen no interplay folder for windows 7

If you downloaded it from steam then it would be found here... C:\Program Files (x86)\Steam\SteamApps\common. at least that is where the ini files are on my machine...
VonStreed Feb 16 @ 6:11pm 
Originally posted by DeepBlue1973:
Doesn't work for me, still got rainbow colors... :(
from the comments beow the suggested fix in the link i posted. Maybe this will help?

"The default installed version of Fallout 1 does display palette shifting color thrashing in the movie playback unless you set the Fallout desktop shortcut(right click/properties/compatibility tab selecting win 95/winxpsp3 and 256 colors ) to run in 256 colors thereby allowing the movies to playback in their native 256 colors but unfortunately the game will also play in its lowest color palette.

There is no default DDRAW.INI file in the Fallout folder of the original Fallout CD and creating one and placing it everywhere in the Interplay folders does nothing to resolve the issue.

If you want to solve the issue you can run the rapidshare linked "FalloutW.zip" Freeware Fallout1 v2.1 Hi Res Patch fix( Big Thanks to its creator "Mash" Matt Wells ).( Can't attach it here due to file size limit of 256k, It's 1mb zipped)

I've added the setting "COLOUR_BITS = 8" to the Movies section of file "f1_res.ini" to set the movie display palette to 256 colors. I have the game set to run at max 16 bit color with a screen resolution of 1400x1050 which you may have to modify but this is my preferred setting for me in terms of highest res without squinting/straining my eyes on my 28In 1080p HD Widescreen Monitor.

You may also have to disable visual themes and modify other compatibility mode settings for Fallout to run
properly."
Doriphor Feb 24 @ 5:57pm 
Just set your desktop background color to black and keep the "screen resolution" window open until you're done playing. Game works out of the box with no compatibility settings etc.. Works for other games with this issue too, like Diablo :)
Last edited by Doriphor; Feb 24 @ 6:01pm
[GP]ゆき隊長 Feb 25 @ 11:20pm 
I had the issue and was able to fix it but I forgot what I did. I think I did this:
1. Find falloutw.exe in the Steam folder
2. Right click and select "Properties"
3. Click on the "Compatiblity" tab
4. Under Settings select these two options: "Run in 256 colors"; "Run in 640 x 480 screen resolution"
5. Click accept and see if that works
Gavener Feb 26 @ 8:32am 
will have to try both these fixes
Django Feb 27 @ 1:47pm 
got these "rainbow colors" in some older games. there is a simple solution which works for all the games. at least if you're using win7 64bit
the trouble is caused by the windows explorer. if you kill the explorer task, then there are no more odd colors in the games.
you can do that by simply creating a textfile with the following content:

TASKKILL /F /IM "explorer.exe"
cd D:\Steam\SteamApps\common\Fallout\falloutw.exe (here you have to put in your fallout folder adress!)
start /w D:\Steam\SteamApps\common\Fallout\falloutw.exe (same here)
start C:\Windows\explorer.exe

then save as .bat file. then start that .bat file. that's all! hope it helps some of you people :)

for the ones who are corious what the .bat file is doing:
It kills your explorer task, starts fallout and after you quit fallout (or any other old game you put in the folder adress) and starts a new explorer task.

feel free to contact me if you have problems creating the .bat file :)
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Jan 6 @ 9:43am
Posts: 15