Psychonauts > General Discussions > Topic Details
Ziyad Sep 5, 2012 @ 8:20pm
Game sounds and frames skip a lot.
So I started the game a while back, and it's fun, but I haven't played much because the game keeps skipping. The skips are tiny but just enough for me to notice, and they are very frequent. Google had some suggestions but they didn't help. Anybody have advice.
Showing 1-8 of 8 comments
< >
Rabbitears Sep 5, 2012 @ 9:56pm 
I started playing it this week after picking it up on the summer sale and I havent had this problem within the 4 1/2 hours ive got in so far. This only thig weird is i did have to reset the aspec ratio from when the game frist lanch cause it was runing in a SD ratio instead of the wide screen i have my card set at.
Rampage_64 Sep 6, 2012 @ 12:34am 
Really? It did have this problem for awhile, but once they updated it two + months ago, seems to run quite smoothly! If you haven't played it that recent, fire it up and if nothing, mess around with them settings bud! (If you haven't already)
Shark Sep 6, 2012 @ 2:38pm 
Disable Aero in windows(you can do that by putting your desktop theme to windwos classic) and enable vsync, that might fix your problem.
[TG]Corpse Oct 15, 2012 @ 4:03pm 
I have this same problem. It makes the game almost unplayable. I am on a brand new laptop. Windows 7 Home Premium, Core i7 3610, GTX 650m, 8GB DDR3. Any suggestions are appreciated. Thanks!
Stray Sheep Oct 18, 2012 @ 5:53pm 
Disable FSAA in the graphics options first. If that doesnt work, change a few more Graphics and Video options. FSAA is a big one though that's completely useless and takes a lot of power.
[TG]Corpse Oct 19, 2012 @ 1:55am 
Thanks for the suggestions. I am not sure which of the following fixed my problem, but it has been fixed...so I will post what I did here:
  • Uninstall game through Steam
  • Delete Psychonauts folder in Steamapps Common folder
  • Reboot
  • Reinstall while installing nothing else
  • Profit
Crunkster64 Oct 23, 2012 @ 6:24pm 
I had this same problem, but it wasn't ALWAYS happening and i didnt care too much for some of the early dialogue cause i still remembered it from my previous playthrough on the Xbox.
▶◖KB◗◀ Oct 26, 2012 @ 1:45pm 
I'm having the same problem. The sound and the frames skips a little, and really mess with the whole gaming experience. My laptop is a GT70, with Windows 7 Home Premium, Core i7 3610, GTX 670M and 12GB. I've tried all the suggestions, but nothing seems to work. Any ideas, anyone?
Tnx
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Sep 5, 2012 @ 8:20pm
Posts: 8