Psychonauts > 综合讨论 > 主题详情
Sarsben 2013年7月25日下午10:24
Trigger buttons on 360 controller aren't working (on Mac)
So, I was trying to play this with my wired Xbox 360 controller on my MacBook Pro. The default button bindings are a bit messed up but once I set them up properly in the options menu everything works perfectly, except for one big problem-- I can't set anything to the trigger buttons. It's as if they aren't being recognized at all.

Of course, I had to download a third party driver to make the controller work on Mac, and the functionality can be a bit spotty, although it works fine in most games I've tried it with so far. I haven't tried playing Psychonauts on Windows yet (I duel boot but try to play on my Mac side whenever possible).

Any ideas? Has anyone else had issues with the analog triggers in this game? I know some older games don't like them but I've heard Psychonauts should work normally with the 360 controller.
< >
正在显示第 1 - 15 条,共 15 条留言
DF Vic 2013年7月26日下午2:13 
You're correct in that the Xbox 360 controller should work well with Psychonauts on Mac. Did you install the TattieBogle driver or a different one?
Sarsben 2013年7月26日下午8:32 
It's been a while since I installed it, but I just double checked and it looks like I got the TattieBogle one. Normally that works with Psychonauts on Mac, then?

I have had controller issues with a couple of games on Mac, but not with the trigger buttons. Like I said, everything else seems to work fine in Psychonauts, so I'm not sure why it won't let me bind the triggers.

Thanks for the reply. I've still been really enjoying replaying the game so far... the keyboard and mouse controls work a lot better than I would have guessed.
Crimsonian 2013年7月30日上午6:48 
I have a similar problem. I was able to bind the right trigger to PSI Power 1 (which Psychonauts shows as button 6) but if I try to bind, say, target lock to the left trigger, the button rectangle area goes from red to green (so it detects something) but no binding is set. All other controller buttons can be bound — it’s just the left trigger that cannot, even though the driver’s preference pane does recognise the left trigger (including intensity). Joystick And Gamepad is also able to recognise the left trigger.

For what it’s worth, I’m running OS X v10.8.4 with a wired Xbox 360 controller and version 0.12 (the latest) of the Tattiebogle driver.
DF Vic 2013年7月31日上午10:26 
Thank you for the detail. We're going to reproduce it locally and then look into a solution.
Crimsonian 2013年7月31日下午7:49 
Thanks for looking into this, Vic. I’d be glad to provide you further information if needed.
Sarsben 2013年7月31日下午9:01 
Yes, thanks a lot for checking this out. My situation seems to be pretty similar to Crimsonian's, except that I can't seem to bind either trigger. Both work fine in other games and when I open up the driver preferences window, though, and the little binding button display does change color briefly when I press the button to register the input... it just doesn't map the action to the button.

I'm on 10.6.8. I'll have to double check on my driver version.
doorknob60 2013年8月9日下午1:50 
I have this same problem in Linux. I can map all the normal buttons just fine, but I can't put anything onto the triggers. I assume it doesn't properly know how to handle the fact that they are analog triggers (not digital buttons), but without the triggers there aren't enough mappable buttons to play the game. A patch for full 360 controller support (including button prompts) would be awesome, if that's possible :)
DF Vic 2013年8月12日下午1:25 
Well, that's just weird.

We've reproduced it locally and added it to our list of stuff to address. I can't say when it'll be fixed, but as always we'll strive to get it into an update. Thank you everyone for your additional details.
Palfrey 2014年4月21日下午12:17 
Any progress on this? Ran into this one today and finding it very annoying!
krayzee911 2015年2月21日下午11:09 
Has this been addressed? I'm still seeing the behavior on Mac, using the tattiebogle driver v 0.14.
Sorsa 2015年4月18日上午7:52 
Oh goodie. Was hoping to find an aswer to my trigger problem... Oh, no answers here.

For whatever it's worth: Can't bind triggers on wired Xbox 360 controller. Ubuntu 14.04

Shame this never got fixed.
Elinor 2015年6月24日下午4:54 
I have got the same issue. Please get this bug fixed.
Elinor 2015年6月30日下午2:02 
Ok i didnt find a solution but i found this as best binding config:


Bugg Mac 2016年12月8日下午5:22 
Apparently everyone working on this has died... Oh well. RIP.
Ditzly 2016年12月13日上午8:08 
To be persistent: has anyone figured this out yet? I've downloaded the newest patch, apparently from TattieBogle, now on GitHub (360 Controller ver. 0.16.4). All buttons/axes maps just fine in the Steam Controller settings; but can't use the triggers in games...using Mac os Sierra.
< >
正在显示第 1 - 15 条,共 15 条留言
每页显示数: 15 30 50

Psychonauts > 综合讨论 > 主题详情
发帖日期: 2013年7月25日下午10:24
回复数: 15