View Stats:
Psychonauts > General Discussions > Topic Details
Sarsben Jul 25, 2013 @ 10:24pm
Trigger buttons on 360 controller aren't working (on Mac)
So, I was trying to play this with my wired Xbox 360 controller on my MacBook Pro. The default button bindings are a bit messed up but once I set them up properly in the options menu everything works perfectly, except for one big problem-- I can't set anything to the trigger buttons. It's as if they aren't being recognized at all.

Of course, I had to download a third party driver to make the controller work on Mac, and the functionality can be a bit spotty, although it works fine in most games I've tried it with so far. I haven't tried playing Psychonauts on Windows yet (I duel boot but try to play on my Mac side whenever possible).

Any ideas? Has anyone else had issues with the analog triggers in this game? I know some older games don't like them but I've heard Psychonauts should work normally with the 360 controller.
< >
Showing 1-15 of 15 comments
DF Vic Jul 26, 2013 @ 2:13pm 
You're correct in that the Xbox 360 controller should work well with Psychonauts on Mac. Did you install the TattieBogle driver or a different one?
Sarsben Jul 26, 2013 @ 8:32pm 
It's been a while since I installed it, but I just double checked and it looks like I got the TattieBogle one. Normally that works with Psychonauts on Mac, then?

I have had controller issues with a couple of games on Mac, but not with the trigger buttons. Like I said, everything else seems to work fine in Psychonauts, so I'm not sure why it won't let me bind the triggers.

Thanks for the reply. I've still been really enjoying replaying the game so far... the keyboard and mouse controls work a lot better than I would have guessed.
Crimsonian Jul 30, 2013 @ 6:48am 
I have a similar problem. I was able to bind the right trigger to PSI Power 1 (which Psychonauts shows as button 6) but if I try to bind, say, target lock to the left trigger, the button rectangle area goes from red to green (so it detects something) but no binding is set. All other controller buttons can be bound — it’s just the left trigger that cannot, even though the driver’s preference pane does recognise the left trigger (including intensity). Joystick And Gamepad is also able to recognise the left trigger.

For what it’s worth, I’m running OS X v10.8.4 with a wired Xbox 360 controller and version 0.12 (the latest) of the Tattiebogle driver.
DF Vic Jul 31, 2013 @ 10:26am 
Thank you for the detail. We're going to reproduce it locally and then look into a solution.
Crimsonian Jul 31, 2013 @ 7:49pm 
Thanks for looking into this, Vic. I’d be glad to provide you further information if needed.
Sarsben Jul 31, 2013 @ 9:01pm 
Yes, thanks a lot for checking this out. My situation seems to be pretty similar to Crimsonian's, except that I can't seem to bind either trigger. Both work fine in other games and when I open up the driver preferences window, though, and the little binding button display does change color briefly when I press the button to register the input... it just doesn't map the action to the button.

I'm on 10.6.8. I'll have to double check on my driver version.
doorknob60 Aug 9, 2013 @ 1:50pm 
I have this same problem in Linux. I can map all the normal buttons just fine, but I can't put anything onto the triggers. I assume it doesn't properly know how to handle the fact that they are analog triggers (not digital buttons), but without the triggers there aren't enough mappable buttons to play the game. A patch for full 360 controller support (including button prompts) would be awesome, if that's possible :)
DF Vic Aug 12, 2013 @ 1:25pm 
Well, that's just weird.

We've reproduced it locally and added it to our list of stuff to address. I can't say when it'll be fixed, but as always we'll strive to get it into an update. Thank you everyone for your additional details.
Palfrey Apr 21, 2014 @ 12:17pm 
Any progress on this? Ran into this one today and finding it very annoying!
krayzee911 Feb 21, 2015 @ 11:09pm 
Has this been addressed? I'm still seeing the behavior on Mac, using the tattiebogle driver v 0.14.
Sorsa Apr 18, 2015 @ 7:52am 
Oh goodie. Was hoping to find an aswer to my trigger problem... Oh, no answers here.

For whatever it's worth: Can't bind triggers on wired Xbox 360 controller. Ubuntu 14.04

Shame this never got fixed.
Elinor Jun 24, 2015 @ 4:54pm 
I have got the same issue. Please get this bug fixed.
Elinor Jun 30, 2015 @ 2:02pm 
Ok i didnt find a solution but i found this as best binding config:


Bugg Mac Dec 8, 2016 @ 5:22pm 
Apparently everyone working on this has died... Oh well. RIP.
Ditzly Dec 13, 2016 @ 8:08am 
To be persistent: has anyone figured this out yet? I've downloaded the newest patch, apparently from TattieBogle, now on GitHub (360 Controller ver. 0.16.4). All buttons/axes maps just fine in the Steam Controller settings; but can't use the triggers in games...using Mac os Sierra.
< >
Showing 1-15 of 15 comments
Per page: 15 30 50

Psychonauts > General Discussions > Topic Details
Date Posted: Jul 25, 2013 @ 10:24pm
Posts: 15