Psychonauts > General Discussions > Topic Details
Claygirl Jul 21, 2013 @ 5:41am
Linux version unplayable
I have Ubuntu 12/04 LTS and every time I turn on the game Raz just runs right - without me pressing anything. If I press left, he will change directions but as soon as button is released he goes back to running right. I have no controller installed/connected and using only mouse and keyboard - bindings are default W, S, A D.
Last edited by Claygirl; Jul 23, 2013 @ 6:50am
Showing 1-15 of 25 comments
< >
w0rkbench Jul 22, 2013 @ 11:09am 
im on linux mint 15 and my camera just spins clockwise.
DF Vic  [developer] Jul 23, 2013 @ 5:14pm 
Hi folks.

I'm sorry to hear that you're having issues running Psychonauts on Linux. Have you tried to uninstall and reinstall the application?
Throctukes Jul 25, 2013 @ 2:53pm 
I'm seeing the same behaviour on Ubuntu 13.04. Raz just runs up & left constantly. Menu control is jittery as well. Again no controller connected, just using mouse and keys with default bindings. It feels like the game is detecting something else as a controller, though I have no idea what. Tried uninstalling and reinstalling and that made no difference.
DF Vic  [developer] Jul 25, 2013 @ 6:06pm 
Additionally, do any of you have other devices plugged in via USB? If so, please disconnect those devices and check if that resolves the issue.
Claygirl Jul 26, 2013 @ 3:25am 
Unfortunately reinstalling the game didn't fix the problem. I have only mouse and keyboard connected via USB.
LonePiper Jul 26, 2013 @ 5:11am 
Odd, I'm having no such troubles and I have a mouse, a trackball and a graphics tablet all plugged in simultaneously. In fact, apart from a couple of possible graphical glitches, this game runs smooth as butter for me. Quite amazed at that considering some of the hoops I've had to jump through in the past to get games to work on linux.

(Glad I don't have to reinstall it really - Australia is still in the stone age, and with the kinds of connection I get it took me probably 5 or 6 hours to download it!)

I wonder - do you guys have any old, spare keyboards lying around? Just a thought, but I seem to recall some time ago having a keyboard that some games just didn't like for some reason and caused similar problems.
zounas Jul 26, 2013 @ 5:28am 
Normally the mouse look doesn't work. If I start the game with a controller plugged in the mouse look sometimes works fine but sometimes the view keeps turning left. Definitely something is wrong with the game. How about adding some controller debug messages to output so we could provide more helpful info?
Throctukes Jul 28, 2013 @ 2:10pm 
I just have a keyboard and mouse, there's nothing to unplug.
Throctukes Jul 30, 2013 @ 3:32am 
In the spirit of experimentation, once the game's running I've unplugged *every* USB device connected to my machine - including mouse and keyboard. Doesn't change the behaviour at all; Raz is still running up and left.
DF Vic  [developer] Jul 30, 2013 @ 3:06pm 
Thanks for the detail. We're going to try this locally and see if we can work out a solution.
Last edited by DF Vic; Jul 30, 2013 @ 6:51pm
Claygirl Jul 31, 2013 @ 2:13am 
If there's any way to provide you with more info (game error logs?) I will be more than happy to help :)
ARK Aug 16, 2013 @ 7:56pm 
This is also a problem for me. It's the only thing wrong. Raz always runs up and left. Mouse controls are fine now that my game is full screen(which it was not by default). No graphics problems and I'm using an XP era laptop from Gateway. Awesome compatibility but the controls are what kill it for me for now. I have faith and will await the fix. OS is Ubuntu 12.04 with Gnome Classic.
Last edited by ARK; Aug 16, 2013 @ 8:01pm
ARK Aug 17, 2013 @ 5:43pm 
I think that the game is interpreting joystick input at 0,0 on an +X,+Y grid rather than a +X/-X,+Y/-Y grid (top left rather than center). I think this is applicable to both joysticks. I use keyboard and mouse for gameplay but this doesn't keep the game from seeing the joystick input at the default start location anyway.
Last edited by ARK; Aug 17, 2013 @ 5:46pm
DF Vic  [developer] Aug 19, 2013 @ 10:39am 
I've investigated this and there does seem to be a problem. This same problem occurs with other games which points toward a driver incompatibility.

For those who have just tried plug 'n play, can you try to update drivers. Here is one for Linux.

http://pingus.seul.org/~grumbel/xboxdrv/

And for Mac, other options besides the TattieBogle driver. Unfortunately these options are not free.

https://itunes.apple.com/us/app/joystick-mapper/id528183797?mt=12

https://itunes.apple.com/us/app/gamepad-companion/id428799479?mt=12
ARK Aug 21, 2013 @ 2:38pm 
"sudo rmmod joydev" fixed the problem for me.
Showing 1-15 of 25 comments
< >
Per page: 15 30 50
Date Posted: Jul 21, 2013 @ 5:41am
Posts: 25