Psychonauts > Discussões Gerais > Detalhes do tópico
The One Who Knocks 16 Nov, 2013 às 20:51
FIXED Xbox controller Issue!
I've seen many complaints about the xbox controller not working (especially the wireless ones), and this fix may apply to you. Many computers have a default gamepad called "HID Compliant game controller" or a "6 direction 24 button hat switch". The problem is the game recognizing the HID controller (which is really nothing, its just always on in some pcs.) as controller 1, and the Xbox one as Controller 2. So...

1. Go to Devices and Printers
2. Right click on HID-Compliant game controller (or whatever the unused controller is)
3. Click Properties
4. Go to the Hardware tab, and click on the HID-compliant game controller. Click properties in the bottom right.
5. Click on the Drivers tab.
6. Click "Disable"

Thats it! Now, any game you play, including Psychonauts, will detect your Xbox controller consistently. This solves the controller issue in many other games too! I hope this helps.

Also, a very simple patch to change the on-screen buttons, to that of the Xbox controller, for easier gameplay. (instead of wondering what to do when it says to press 'e'"

http://dl.dropbox.com/u/75754626/PsychoPadLite_v1.1_install.rar
A mostrar 1-15 de 26 comentários
< >
aquarius0 17 Nov, 2013 às 3:07 
Thanks!
The One Who Knocks 17 Nov, 2013 às 6:33 
np!
Psiklops 20 Nov, 2013 às 17:42 
I was excited to try this, but unfortunately Psychonauts still doesn't work with my xbox controller. :-(

For the record, I had no HId-compliant game controller listed until I turned on the xbox controller, so maybe I have a different problem.
The One Who Knocks 20 Nov, 2013 às 17:46 
make sure you have the right drivers downloaded, you can get them off of Microsofts site. Check drivers, then make sure your controller is on BEFORE the game is booted up, or it wont recognize it. Lastly, once your xbox controller is on, it should show up in your Devices and Printers as "Xbox 360 Controller", and the HID Complaint one should be seperate. It sounds to me like your pc thinks the xbox controller is just a standard pc controller, making me think your dirvers arent there. but idk lol. Let me know if that works for you.
Psiklops 21 Nov, 2013 às 17:38 
Thanks for the suggestions, but no luck. I downloaded the drivers again to be sure and it told me I had the correct drivers already installed. I always turn on the controller before launching a game. BTW, the HID compliant game controller doesn't show in "Devices and Printers" for me, though it does show up in device manager under the HID section. (win7x64)

I bet you're right about the detection being the problem. I've had the controller not work on a couple of other things, though it is fine for most.
Psiklops 21 Nov, 2013 às 17:45 
I figured out the problem. I have a Belkin n52te keyboard/controller attached and Psychonauts is using that instead of the xbox controller. Now if I can figure out a way to make it stop doing that. unplugging it didn't work.
The One Who Knocks 21 Nov, 2013 às 18:19 
Ok, go into your devices and printers, and right click the xbox controller. Go to Game Controller settings, and you should be able to click "Advanced" and set different priorities. And, did you disable the HID compliant controller from within the device manager?
Última alteração por The One Who Knocks; 21 Nov, 2013 às 18:20
The One Who Knocks 21 Nov, 2013 às 18:21 
Like, itll give you choices. "When xbox controller is plugged in, use (x) device"
Make sure its set to your controller, not the keyboard.
BakeACake 21 Nov, 2013 às 23:02 
Thanks for this, patch worked! Now I can actually press buttons in menus without fearing what they'll do.
Psiklops 22 Nov, 2013 às 13:15 
Yeah, I already had the xbox controller set as the preferred device and the HID compliant controller disabled but Psychonauts still uses the n52te. I tried disablig the virtual HID devices too (that is how the belkin controller is listed), but no dice. At least I know what the problem is now; maybe I'll have a brainstorm one day and figure out how to get it working.
The One Who Knocks 22 Nov, 2013 às 13:55 
Youre welcome, Bake a Cake! And, one last thought... did you try setting the belkin device, to "prefer" the xbox controller? Just go in game controller settings on the Belkin, and click advanced and set preferred device to the xbox controller. If that doesnt work, then Im all out of ideas. Sorry man.
Psiklops 23 Nov, 2013 às 20:31 
You can't set a preferred device for each device, but rather for the device category. So, for "game controllers" I can set either the xbox controller or the virtual Hid device as preferred.

I'm thinking that perhaps windows just enumerates usb devices as they're found and if I can find a way to switch the order then maybe things will work the way I want. I also thought about uninstalling the device and reinstalling but just haven't been that motivated yet.
TheSunshyn 22 Dez, 2013 às 19:27 
Thanks for the inforrmation. I'm on Win7 and seemed to have the same problem with my Nostromo gamepad as Psiklops did. I had the option to set the Nostromo or x360 to preferred. However, after I disabled the HID compliant controller the option to set the preferred device to the x360 controller goes away. The game still won't see the xbox controller.

BTW, it never shows up in devices and printers as "Xbox 360 Controller", just "Controller" which contained Xbox 360 Controller and USB Input Device (had HID compliant controller listed in the same box until after I disabled it and restarted.
The One Who Knocks 22 Dez, 2013 às 19:30 
if it only shows as "Controller", it sounds to me like you need the right drivers. But im not sure. Try Microsofts website, and downloads the latest drivers. See if that helps anything.
A mostrar 1-15 de 26 comentários
< >
Por página: 15 30 50