Psychonauts > General Discussions > Topic Details
MooseMoose Jan 20 @ 2:52am
360 Controller Bug
I've been experiencing the most bafflling bug with this game.
The game works perfectly fine for the most part, it automatically detected my 360 controller and worked just fine... except one button.
The right trigger refuses to function properly.
I can use the left trigger to lock on perfectly fine no problems, but no matter what I do I cannot use the right trigger to fire off any psi powers. The bumpers work perfectly fine for using psi powers, just not the right trigger. It seemed completely unresponsive at first, but after checking the calibration of the triggers (it was perfect) and recalibrating anyways (it still looked perfect) the game has now decided to randomly fire off whatever power is in slot one.
The controller works perfectly with every other game, it is only this one that the right trigger behaves oddly with. I've made sure no other controllers or tablets devices are plugged in, I've downloaded the latest drivers for the controller, I recalibrated it several times, I even tried joytokey to map the trigger to a button, but the game refuses to recognise any keyboard input (or even right click) for the first psi power slot when the controller is plugged in.
Hours of Google-fu has failed me completely. Help?
Showing 1-5 of 5 comments
< >
andrewb Jan 21 @ 11:00am 
Got exactly the same issue with right trigger except I was having it in pretty much all games. The trigger was not registered by games (guacamelee for example, it would only register when I press it really fast, the same with psychonauts). Also had the same problem when the function assigned to right trigger won't work if I tried to press corresponding button on a keyboard, as if the controller was blocking it. It started working when I unplugged the controller :/ Also I did not notice anything during calibration...everything was perfect there for me too.

I decided to try and install a different driver (XBCD) which detects the trigger as a button instead of axis and on the screen where you can see all the buttons on the controller (devices and printers-xbox 360 controller-game controller settings-properties) when I pressed the trigger, the button on the screen lighted up but when I released it it didn't turn off...so the trigger was getting "stuck" preventing games from registering me pressing it again or at least that's what I figured out.
In the end I decided to claim a refund or a new controller since I think the trigger on this one is broken and I only had it for like a week lol...it's not supposed to be screwed up like this I don't think. If they reject it I'm gonna be real ♥♥♥♥ed, the controller was not cheap and it's practically useless in it's current state -.-

Btw I noticed you played dark souls which I also played with the controller and it worked just fine...not for psychonauts and many other games though :/ I bet you if you tried it in different games it wouldn't work so well either. So yea if I'm right it's possible that your trigger is simply broken.

*Sry for making this so long, I just wanted to post all the info that I gathered during last week when I was desperately trying to get my controller to work...failing x)
Last edited by andrewb; Jan 23 @ 7:55am
MooseMoose Jan 22 @ 6:32pm 
Hm...
Well I've tried the controller with multiple games (not just Dark Souls), and I have had absolutely no problems with any of them, except Psychonauts.
The only other place I had troubles with the controller was tryng to use it with xpadder, which seemed to have the same issue with the controller as psychonauts does. It registers the right trigger as always being pressed. Absolutely no other programs have this issue for me though. Just Psychonauts, and Xpadder. Using Xpadder to get a closer look at the controller calibration though I CAN see that it is very slightly off. It is a very small amount but the calibration of the right trigger is very slightly off. And no amount of recalibration seems to fix it. Maybe this is the issue? It might actually be a hardware defect like you've suggested, but if it is then why isn't it affecting any other games? This is still really confusing.


Oh, by the way, I managed to get around the issue by just changing the control scheme in Psychonauts to use the B button instead of the trigger and moving 'cancel' to the d-pad. Not really a 'fix' for the issue, but I can play the game just fine at least.
andrewb Jan 23 @ 7:45am 
What I THINK is causing this is that different games register the trigger differently, in some games you have to press it like halfway down for the game to register it (those games wouldn't have any problems...dark souls for example), but in some games it's enough to merely touch the trigger and the game would register it, and those games would actually have problems with this since the game would see the trigger as always pressed, therefore not registering it at all or behaving really weird...if that makes any sense. It does to me anyway :D

*I think that setting some deadzone to the trigger might fix this issue but I don't know how to do that or if it's even possible. (maybe Xpadder can do it? I don't have it so idk)

**I had issues in these games:
Just Cause 2 (planes and helicopters refuse to slow down)

Saint's Row 3 and 4 (cars refuse to go backwards)

Guacamelee (right trigger is not registered at all, it is also obstructing the keyboard button for the in-game function so I can't even use joy2key to fix it)

Psychonauts (Exactly same as Guacamelee)
Last edited by andrewb; Jan 23 @ 7:56am
MooseMoose Jan 23 @ 4:34pm 
Yeah, Some things seem to register the triggers very differently. That's definitely why onle some programs are having this issue.
Xpadder does indeed have a deadzone setting, but no matter how high I raised it I still had the same issue. There seems to be some weird hardware fault with the trigger. That's the only explanation I can come up with for this odd behavior and the fact that it is impossible to completely calibrate the triggers.
I'm just gonna go off and get a new controller. This one is too small for my tastes anyways. Oh well.
MooseMoose Jan 23 @ 7:47pm 
Bit of an update on this issue:
I went and bought a better controller. It works perfectly. No sign of any of these issues. So it was definitely a problem with that particular controller. I still don't know if it was broken or what, but I got a new official actual 360 controller and not some third party crap and it works perfectly fine now. My old controller was a PowerA Mini 360 controller so if anyone out there has this same issue with that model of controller, and manages to google their way here to this post:
Do yourself a favor and just buy a new one.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Jan 20 @ 2:52am
Posts: 5