Psychonauts > General Discussions > Topic Details
Marlowe Feb 7 @ 6:20am
Graphic issues: help!
I am encountering a problem while playing Psychonauts. The objects appear and disappear as I turn the camera or when I move my character. It happens almost always. Trees, bushes, and other stuff appear and disappear. I don't know the correct technical term, it is probably flickering. Look at the pictures to realize.

Image 1[i.minus.com]
Image 2[i.minus.com]
Image 3[i.minus.com]

Does anyone have the same problem? Do you have solutions?

My system:
Win8
Intel i7 3770
AMD Radeon HD 7850
The drivers are updated to the latest version, Catalyst 14.1.
Showing 1-15 of 24 comments
< >
Zorak Feb 8 @ 11:41am 
I have your problem as well. Bump. It's weird texture flickering.
Last edited by Zorak; Feb 8 @ 11:42am
wackattack Feb 8 @ 5:22pm 
Same issue, no idea where the problem is though.

System:
Win7 x64
Intel i5 4670
AMD Radeon HD 7700
Zorak Feb 8 @ 6:07pm 
I have a 7770... we all have 7000 series. Perhaps it could be driver issues.
Marlowe Feb 9 @ 1:16am 
I opened a topic on Double Fine official forum.
Here the LINK[www.doublefine.com].
No response at the moment.
Last edited by Marlowe; Feb 9 @ 1:16am
Marlowe Feb 9 @ 1:17am 
Originally posted by Zorak:
I have a 7770... we all have 7000 series. Perhaps it could be driver issues.

Which driver version do you have? 14.1 beta too?
Zorak Feb 9 @ 2:05am 
Yep, i got the beta as well.
wackattack Feb 9 @ 6:16am 
I was thinking drivers too... I tried it with the previous version (13.12?) and no difference.
piripiago Feb 9 @ 4:45pm 
I have a 7770 also, and I haven't noticed this problem. Have you tried fiddling with the graphics options? I was having other weird problems that went away when I turned V-Sync on.
Dick Drizzle Feb 9 @ 5:49pm 
could it be the fact of your card being AMD? some games just dont go well with AMD
Marlowe Feb 10 @ 1:54am 
Originally posted by piripiago:
I have a 7770 also, and I haven't noticed this problem. Have you tried fiddling with the graphics options? I was having other weird problems that went away when I turned V-Sync on.

Yes, I already tried to disable all the graphics options, change resolution, run it in compatibility mode, check the cache, disable steam overlay in game without any result.
Marlowe Feb 10 @ 10:42am 
Hello guys, i solved the problem changing the drivers. I replaced 14.1 beta with 13.2 WHQL. Now there's no problem and the game goes well.
Zorak Feb 10 @ 4:11pm 
Nice, i'll have to give that a try in a bit. Thanks.
Anyone got Borderlands 2? Apr 17 @ 8:11am 
i have the exact same problem on my hd 7850 2gb, It's a shame the new drivers caused this, i hope that they come out with a new driver that fixes this issues :p
ShadowNate Jun 20 @ 10:04pm 
I just wanted to add here that I had the same graphic issues (the game textures phased in and out of existence and it was very annoying - made the game unplayable for me).

I have a 7950 AMD card 3GB GDDR5, and I had the texture glitch issue with the latest stable and WHQL certified 14.4 drivers for Windows 7 (SP1) x64.

Uninstalling the drivers and reverting to the 13.12 (previous stable) version fixed the issue entirely for me and now I can play with all graphic settings enabled.

I would be great if someone (perhaps better a member of the developer team) talked with AMD about this issue. It sounds like something that should not be happening with new drivers, and I don't think it is an optimal solution to revert to old drivers just for one game.
Marlowe Jun 21 @ 12:30am 
I agree with you. I also tried the 14.4 and glitches persist.

The 13.12 are the latest stable drivers to work with Psyconauts, unfortunately.

Annoying
Last edited by Marlowe; Jun 21 @ 12:31am
Showing 1-15 of 24 comments
< >
Per page: 15 30 50