Psychonauts

Psychonauts

View Stats:
Psychonauts > General Discussions > Topic Details
Object flickering
Hey everybody,

I've bought the game Psychonauts yesterday, seeing people praise it left and right suddenly.

Unfortunately, whenever I play, a lot of models (Most trees, planks, and other static objects around) flicker whenever the camera moves around. This is extremely distracting and effectively makes the game unplayable.

I've rebooted my computer, my drivers are up-to-date, I've reinstalled directX latest version, and this is the only game I've played to suffer from such glitches.

I'm playing on a VTX3D R9 290, and the only unusual thing in my configuration is probably my 2560*1440 96hz screen (although the same phenomenon happens on my other regular 1080p 60hz display).

I've tried tinkering with the display settings (turning on and off fullscreen, AA, and every other option) without any sort of result but the expected behavior.

I couldn't really find people having the same sort of problem, except maybe on winehq or people playing on a mac (I'm playing on windows 7).

Any idea is welcome!

EDIT : my bad, this http://steamcommunity.com/app/3830/discussions/0/558747287594985726/ is exactly the same problem as I have. It appears there are still no fix as of right now...
Last edited by Cafe Dazzlehoff; Jul 25, 2014 @ 2:33am
< >
Showing 1-6 of 6 comments
The Person Aug 14, 2014 @ 7:22pm 
I dont konw if you do or not, but if you have integrated graphics (Intel HD 3000/4000/etc), you might enable those and play it on those. My R9 290 is also having trouble- it seems to be an AMD issue. However, my integrated HD 3000 plays it pretty well, at least well enough to be enjoyed.
Cafe Dazzlehoff Aug 16, 2014 @ 12:57pm 
I do have an integrated HD4000 APU, you're right, I didn't think about that. I'm afraid this would probably drastictally reduce my performance, but this seems like an excellent idea in the meantime, thanks.
timbone86 Dec 6, 2015 @ 9:32am 
The best way to solve this problem is to change your settings. Change Multisampling to Adaptive Multisampling. I don't know if you have Radeon. But mine was under Radeon Setting > Gaming > Globel Settings. You should see an option to change it. I know that fixed the flickering.
A2BS Dec 6, 2015 @ 10:32am 
i have this problem too!
SuperDean Dec 6, 2015 @ 10:17pm 
Try updating Direct X. That solves most problems with this game.
Thanrik D'ean Dec 14, 2015 @ 4:23am 
Originally posted by timbone86:
The best way to solve this problem is to change your settings. Change Multisampling to Adaptive Multisampling. I don't know if you have Radeon. But mine was under Radeon Setting > Gaming > Globel Settings. You should see an option to change it. I know that fixed the flickering.

Thank you this worked for me!
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Psychonauts > General Discussions > Topic Details