Hotel Giant 2

Hotel Giant 2

View Stats:
lakesideguy Oct 21, 2013 @ 12:30am
Hotel Giant 2 and graphic issues on Windows 8 solved and compatiblity settings automatically applied
First, Windows 8.1 will automatically configure this title for compatibility mode. This is one of the nice features of the new Windows 8.1 upgrade and the game now works.

Second, after launching and you see the cut scenes of advertisement you will briefly see the buildings rotating and your menu for a few seconds. Then it may all disappear into a bright white light leaving just the menu.

Click option and go into the video options and torward the bottom , I think 3rd one up from the bottom of the list it will say "glow effect" and is set to low. Turn it off and your buildings will come back. By default it is set to low but the the glow doesn't work. This is not the same as the full scene glow option torward the top. That one works as it makes things shiny like gold.

Last, when you exit the game Windows 8.1 will ask you to save settings as upon launch it will not ask you it automatically detects the title as legacy with problems and auto appies it without your knowledge. That is until you exit and windows asks you if the game worked or not and to save settings. Obviously , save them and have fun playing a game that didn't run before.

Windows 8.1 I welcome it's automatic game legacy detection and application of settings.
Windows 8 did not do this but no more. They made gaming compatibility much better.
This occurred (and the graphical glitch) on Windows 8 Pro with Media Center 64 bit.

I have the STEAM copy, Gamersgate 2012 Edition and Amazon download and all three have this issue.

Good luck!
Last edited by lakesideguy; Oct 21, 2013 @ 12:36am
< >
Showing 1-1 of 1 comments
Clareyboy Dec 4, 2013 @ 2:53am 
Windows 8.1 here too, game works fine for me with graphics settings on maximum. Only thing is that the resolution is stuck on 1280x1024
< >
Showing 1-1 of 1 comments
Per page: 15 30 50