Aztaka > General Discussions > Topic Details
Rachskald Jul 31, 2013 @ 5:52am
Underworld protection utterly broken? Some conclusions.
After playing this game for a while (I'm level 13 or so now) I noticed underworld protection spell is broken badly - first of all, no matter how many points in it, or in related stats, it always only increases your defense by 1. Jup, that's right, a whole point. But it get's much worse. This point leaves you when you enter another area. BUT THE SHIELD GRAPHIC EFFECT STAYS, AND THE COOLDOWN STILL APPLIES What this means is this; when your shield lasts a few minutes, you have to wait ages to be able to recast it when you enter a new area. Meanwhile, you walk around with a shield animation but NO SHIELD. Apart from the fact that that one defense seems... lacklustre to say the least. The ♥♥♥♥, developers? Any ideas/ fixes etc?
Showing 1-2 of 2 comments
< >
glorfindel1975 Aug 20, 2013 @ 2:23am 
This game is full of bugs. I bought it on Gamestop/Impulse and tried it two times. I was never able to finish the game because of a bug into the vulcan where the phonogram did not appear.
Initially the developers attended this forum, but now the game looks abandoned, and their website is quite dead...
casounds Aug 23, 2013 @ 10:25am 
the skill points only add to the cool down. I never put more than 4 points on it even at games end. It should how ever double the defence stats. The defence depends on equipment....
Showing 1-2 of 2 comments
< >
Per page: 15 30 50