Rusty Hearts > Discussões gerais > Detalhes do tópico
Captain Morgan 13/jun/2013 às 14:43
[FIX] Some fixes for some problems
Hello!

I am not 100% sure if this is fully working fix but this is how i get it working:

Before anything, open your taskmanager (ctrl+shift+esc) and open prosesses tab and check if windygamelauncher.exe is running, if it is, terminate it.

[FIX] Stuck on patching?
­- So you have got stuck on patching? Do this:
1. Go to your Rust Hearst install folder ( ex. F:\SteamLibrary\SteamApps\common\Rusty Hearts ) This might differ on yours as i have installed it on other drive.
2. Run MPatcher.exe - This will install currently downloaded patch (ex. got stuck on 99.1%)
3. After patcher is done, run ClientLauncher.exe and it will download the rest of it and installs it succesfully. If not, try MPatcher.exe again.
4. It should be working now!

[FIX] Rusty Hearts won't launch on steam, see only blink of launhcer?
- This one has been bugging me, but i think i found way to get it work
1. Add MPatcher.exe as a non-steam game and add it as favorites
2. Run Mpatcher.exe before starting Rusty Hearts and you will be able to play thro steam.

[FIX] Black screen after log-in
1. Update your DirectX LINK[www.microsoft.com]
2. If still occurs, Update graphic card drivers
Nvidia drivers LINK[www.nvidia.com]
AMD drivers LINK[support.amd.com]

This is only my way to fix it and it might not work 100%
Thank you for reading, if you know someone has this problem, link this thread to your friend or to someone who needs help with this. Also if this didin't work, please tell me :) so if this works for you, it could work for many other and this post could get sticked/pinned :)))

NOTE: If you "Verify integrity of game chache..." It will load the game to earlier patching and you have to patch your game again, so i do not recommend to do this.
Última edição por Captain Morgan; 10 de mar às 12:12
Exibindo comentários 115 de 71
< >
Brock Samson 29/jun/2013 às 2:02 
Worked for me. Good solution.
Captain Morgan 29/jun/2013 às 10:26 
Escrito originalmente por shadiasghost:
Worked for me. Good solution.
Thanks. I noticed that i have removed pandora media booster and that might be one reason for game to not work propely for me. I might try removing all registrys for that game and install it again as a "clean install" ^^
MonkeyboyGWW 8/jul/2013 às 12:43 
Im trying it now. Please work!
Senorlil 9/jul/2013 às 17:05 
Wow thank's, it worked perfectly for me )°(
Captain Morgan 10/jul/2013 às 2:37 
Escrito originalmente por Vocaloid Senorlil:
Wow thank's, it worked perfectly for me )°(
Glad to hear that :)
darkatsuma 11/jul/2013 às 2:07 
[FIX] Rusty Hearts won't launch on steam, see only blink of launhcer?
- This one has been bugging me, but i think i found way to get it work
1. Add MPatcher.exe as a non-steam game and add it as favorites
2. Run Mpatcher.exe before starting Rusty Hearts and you will be able to play thro steam.

im a newbie how do i do that????
Última edição por darkatsuma; 11/jul/2013 às 2:13
darkatsuma 11/jul/2013 às 2:44 
nevermind i found out how but it never worked. rusty hearts still wont load up
FearMyBacon 15/jul/2013 às 18:58 
thanks a lot this really helps :)
Moni 16/jul/2013 às 11:53 
I did as you say but I get an X-Trap error message :

Code field : 02-0300-00000000-017
System is not in admin account or some functions of the operating system are not working properly.

I did it as the admin though...
Captain Morgan 16/jul/2013 às 13:08 
Escrito originalmente por Moni:
I did as you say but I get an X-Trap error message :

Code field : 02-0300-00000000-017
System is not in admin account or some functions of the operating system are not working properly.

I did it as the admin though...
Are you on administrative account? You can try disabling UAC (user account control), I myself don't use UAC as i don't feel like needing it. Also did you run it as administrator? Like Right click on the launcher and select "Run as administrator" from there :P
Aero_X_999 20/jul/2013 às 0:58 
I just done update the MPatcher.exe but after that I got X-Trap error message...

Here my screenshot of this error message. http://i976.photobucket.com/albums/ae245/Aero_X_999/Screenshot20.png
Última edição por Aero_X_999; 20/jul/2013 às 1:05
Captain Morgan 20/jul/2013 às 6:03 
Escrito originalmente por Epic Or Not To Be Epic?:
I just done update the MPatcher.exe but after that I got X-Trap error message...

Here my screenshot of this error message. http://i976.photobucket.com/albums/ae245/Aero_X_999/Screenshot20.png
What firewall are you using? If you for example use Fsecure, then you need to allow Mpatcher/xtrap or something like that. Also check if running administrator helps. Sometimes portforwarding your router might help.
Aero_X_999 21/jul/2013 às 1:34 
Escrito originalmente por Captain Morgan:
Escrito originalmente por Epic Or Not To Be Epic?:
I just done update the MPatcher.exe but after that I got X-Trap error message...

Here my screenshot of this error message. http://i976.photobucket.com/albums/ae245/Aero_X_999/Screenshot20.png
What firewall are you using? If you for example use Fsecure, then you need to allow Mpatcher/xtrap or something like that. Also check if running administrator helps. Sometimes portforwarding your router might help.

I tried it as you suggested, none of them works. I got another error during patching, here the screenshot of the error message. http://i976.photobucket.com/albums/ae245/Aero_X_999/Screenshot21.png
Captain Morgan 21/jul/2013 às 2:48 
Escrito originalmente por Epic Or Not To Be Epic?:
Escrito originalmente por Captain Morgan:
What firewall are you using? If you for example use Fsecure, then you need to allow Mpatcher/xtrap or something like that. Also check if running administrator helps. Sometimes portforwarding your router might help.

I tried it as you suggested, none of them works. I got another error during patching, here the screenshot of the error message. http://i976.photobucket.com/albums/ae245/Aero_X_999/Screenshot21.png
Now you should try mpatcher if it patches anything and then run that launcher client again ;P
Aero_X_999 21/jul/2013 às 11:51 
Escrito originalmente por Captain Morgan:
Escrito originalmente por Epic Or Not To Be Epic?:

I tried it as you suggested, none of them works. I got another error during patching, here the screenshot of the error message. http://i976.photobucket.com/albums/ae245/Aero_X_999/Screenshot21.png
Now you should try mpatcher if it patches anything and then run that launcher client again ;P

Tried it again, still not work, got error message again.
Exibindo comentários 115 de 71
< >
Por página: 15 30 50