Rusty Hearts > General Discussions > Topic Details
kodyd194 Mar 14, 2014 @ 3:52am
Rusty Hearts not starting
I have been looking every where and have done pretty much everything shy of contacting support, I figured I would ask here in the Rusty Hearts steam community if they have any ideas. My problem is that after patching and pressing start game/ play I go to the select server/ realm window. after selecting east (or west or any other server I want to play) xtrap will load in the bottom of the screen and magi patcher at the top, then everything closes. Nothing happens after that it just crashes the client to desktop no X-trap message or anything. I havent managed to get it to work right and I am open to anyones ideas. I will let you know if I have tried it already, (probably have I have been trying to fix this for days).
Showing 1-15 of 35 comments
< >
Cloudeh Mar 14, 2014 @ 4:26am 
Try reinstalling it and have it patch twice. For me, It worked due to it not fully patching so I had to stop it and restart the client.
kodyd194 Mar 14, 2014 @ 5:25pm 
yea that also happened to me, it would stop patching at 99.1 with some type of chas shop halloween coat button patch file error so I would have to restart the patcher. it would work right the second time, at least until I select a server then it would just load magi patcher and xtrap and stop. I am assuming it is crashing because everything is closing, it could just be that the game is not launching the exe or something. I dont know. thanks for the suggestion though.
kodyd194 Mar 14, 2014 @ 6:59pm 
I have also found a good handfull of people disccribing the same issues with launching the game, it seems none of them have gotten a fix so it is looking a little hopeless. I am still open to suggestions though.
RapazDaPeixefrio Mar 15, 2014 @ 2:02am 
hmmm maybe you could try to check the game integrity, and try to patch again. also this happened to me , im trying to get a fix aswell
kodyd194 Mar 15, 2014 @ 2:10am 
I have done it all, at this point im not even certain there is a reasonable fix. Hopefully sometime in the next few days we get someone posting here who is more knowledgeable on the subject. The internet is filled with people complaining about X-Trap and the problems it causes. I think it does more harm than good with the number of people I am seeing who cant get the game to work because of it, not that I am saying X-Trap is to blame, I just dont know why we still find it in games in 2014.
kodyd194 Mar 18, 2014 @ 4:10am 
Update: never found a fix to get the game to work with steam.
LightThief Mar 21, 2014 @ 12:24pm 
i have same problem with u :(
kodyd194 Mar 21, 2014 @ 5:53pm 
it seems alot of people are having issues with geting the game to work, this did not help me but to solve some of the issues try to launch the game withough steam running by going to the games folder and launching the game from there. that seems to help a good ammount of people if they dont find a solution any other way.
Green Arrow Mar 21, 2014 @ 10:57pm 
the same problem too
Junior Mar 21, 2014 @ 11:13pm 
what exactly is the problem? patching or Xtrap?
could post a screenshot? would greatly help
kodyd194 Mar 21, 2014 @ 11:20pm 
I cant, no the game just completely crashes (no error messages or popups) after selecting a server. Magi patcher and xtrap do appear for like 0.5 - 1 second (after it is already patched the first time) but then everything just shuts down. So no screenshots because there is not anything to see.
Junior Mar 22, 2014 @ 12:22am 
what is your OS, antivirus?
where you download client?
go to rusty hearts folder and delete xtrap folder
download this Mpatcher and replace http://www.mediafire.com/download/mckf6nzk2k1ko3a/MPatcher.exe

kodyd194 Mar 22, 2014 @ 1:34am 
windows 7, Malwarebytes, steam
Junior Mar 22, 2014 @ 1:55am 
first go to your Rusty Hearts folder steam/steamapps/commom/Rusty Hearts
delete Xtrap folder and download this Mpatcher and replace http://www.mediafire.com/download/mckf6nzk2k1ko3a/MPatcher.exe
disable Malwarebytes and try run rhe game.
if not work download this client http://rustyhearts.perfectworld.com/download/client
kodyd194 Mar 22, 2014 @ 3:41am 
the first thing I tryed was disabling antivirus and firewall, ill try again this time along with deleting the xtrap folder, if that doesnt work ill try it again with the non steam client
Showing 1-15 of 35 comments
< >
Per page: 15 30 50