The Implication Nov 13, 2013 @ 6:18am
Game refuses to launch on Mac
I've tried launching this game on every graphic setting both windowed and not. Everytime it immediately tells me that Foreign Legion quit unexpectedly. Please help!
Showing 1-15 of 16 comments
< >
Etc_Guy Nov 28, 2013 @ 8:45am 
I'm having the same problem. I just bought it today.
Last edited by Etc_Guy; Nov 28, 2013 @ 8:45am
Newbtastic Gamer Nov 28, 2013 @ 3:07pm 
I also have this problem any fixxes?
The Implication Nov 29, 2013 @ 3:36pm 
Sorry guys, I haven't heard anything either. Kind of wish steam had the same return policy of the worst company in america.
Newbtastic Gamer Dec 2, 2013 @ 7:35pm 
wow still no help?
Etc_Guy Dec 3, 2013 @ 7:33pm 
I'm pretty certain, it has some to do with the maverics update. Most (at least alot) of pc games that were converted to mac had this same problem(, Garry's mod did).
The Implication Dec 3, 2013 @ 7:52pm 
Anyone trying to run it on Mac Osx before Maverick?
Marinn Dec 19, 2013 @ 5:30am 
Im having the same problem
Crubs Dec 22, 2013 @ 2:20am 
Same problem... any help ?
jawenforcement Jan 9 @ 4:50pm 
No launching for me either. This sucks. Broken games shouldn't be allowed to be sold.
KeropokLekor Mar 21 @ 8:30am 
same problem..not fix yet??

mac os maverick
The Implication Mar 22 @ 12:39pm 
Originally posted by KeropokLekor:
same problem..not fix yet??

mac os maverick

yep...
Mira86 Mar 27 @ 7:36am 
yep me too... same problem
The Implication Mar 31 @ 3:36pm 
Originally posted by Mira86:
yep me too... same problem
Hey Mira86, welcome to the club!
Salc Apr 25 @ 2:03pm 
this game sucksssss we should contact the developers
Malcolm Tucker May 26 @ 4:56pm 
Same issue, developer has not issued any kind of response in almost half a year. Valve ought to start billing them for refunds, this is unacceptable.
Showing 1-15 of 16 comments
< >
Per page: 15 30 50