Trine > General Discussions > Topic Details
tw1l1ght May 19 @ 10:22am
Game goes black while playing
Hi all,

I'm not able to complete even the first level because the game goes black randomly while I'm playing, and I have to press CTRL+ALT+CANC to go back to desktop and revert to the game, but it's pretty annoying, because I have to do it almost 2-3 time per minute!

Is is something already happened to somebody? Is it driver-related? I'm running an nVidia GeForce 520MX on a Win7 laptop.

Thanks in advance for help.
Showing 1-11 of 11 comments
< >
RiikkaFB  [developer] May 20 @ 12:44am 
This could be driver related. Have you tried updating your drivers? If so, could you try that and see if that makes any difference? Have you had this issue with any other games?

You could also try to verify your game cache through Steam (right click Trine from the Steam Library -> Properties -> Local files tab -> "verify integrity of game cache...") in case there is something wrong with the game's files.

You could also see that your PhysX drivers[www.nvidia.com] are up to date.

If nothing above helps, could you also give us your other system specifications? Let me know how it goes. :)
tw1l1ght May 20 @ 3:22am 
Thanks for the answer.

I verified the cache and after few times all the files were okay. I played the game lowering a bit the graphics details (medium settings, no filters, 1366x768 resolution) and it went black less times. I noticed that the issue started when the GPU started heating, not before.

I'm running nVidia drivers 335.23 with PhysX 09.13.1220. I'll update them as soon as possible, but I would like to know if there are known issues with this version.
RiikkaFB  [developer] May 20 @ 3:56am 
From that it does sound like this is an overheating issue. Unfortunately it does seem like your computer just might not have enough power to run the game properly.

You said that lowering the graphic details a bit helped a little. Could you try to use the minimum settings and see if that helps? You could also try to run it in windowed mode. If your computer has gathered a lot of dust, that might also be the cause of this. Please also make sure you don't have any other programs running in the backround while you are playing the game.

I hope that helps. :) Let me know how it goes.
tw1l1ght May 20 @ 2:58pm 
Using the lowerst details available the game goes on flawlessly.

I think the dust owned me! :(

Thanks for all the support! The game is great, hope to have more fun with higher details ASAP!
RiikkaFB  [developer] May 21 @ 2:34am 
Good to know you got it working! :) Unfortunately it does seem like your graphic card does not meet the system requirements, so there's really nothing we can do to improve the situation on our end. I do recommend cleaning your computer of dust on a regular basis though, as that will prolong your computers life and likely also help to keep games running smoother. If you have never done this before, I recommend doing a little research on how to do this. This video for example might be helpful.

I hope you have fun with the game. Cheers. :)
tw1l1ght May 22 @ 10:21am 
Thanks for the advice, much appreciated! :)
Elyuk May 24 @ 12:02am 
this helped me too, thanks !
MeloSon Jun 1 @ 2:43pm 
Seems this game has some issues getting the same thing. Can run Arma 3 on high settings be not this game. Even on low settings goes to not responding. Verified files and all is well. Anyone finds a fix let me know.
RiikkaFB  [developer] Jun 3 @ 3:02am 
Originally posted by MeloSon:
Seems this game has some issues getting the same thing. Can run Arma 3 on high settings be not this game. Even on low settings goes to not responding. Verified files and all is well. Anyone finds a fix let me know.
Could you specify your issue a bit more? Do you mean you get the "Trine is not responding" message? Or do you have the same issue as the original poster (a black screen), or something else? Could you tell your operating system and other system information?

It does sound like something isn't right, and we'll gladly try to help once we know a little more about your issue.

If your game crashes, you could try to update/install the newest PhysX drivers[www.nvidia.com] and see if that helps. Try to restart the computer after installing the drivers, before starting the game. You could also check out this thread[frozenbyte.com] in case there is something there that helps you.

Let me know if anything I said helps, or just a little more about your problem. Cheers. :)
tw1l1ght Jun 6 @ 9:11am 
Hey, I just would like to make you know I removed the dust and changed the thermal paste on the CPU and GPU, and now the game works flawlessly :)
Last edited by tw1l1ght; Jun 6 @ 9:12am
RiikkaFB  [developer] Jun 8 @ 9:57pm 
Originally posted by tw1l1ght:
Hey, I just would like to make you know I removed the dust and changed the thermal paste on the CPU and GPU, and now the game works flawlessly :)
Glad to hear that! I hope you have fun with the game. :)
Showing 1-11 of 11 comments
< >
Per page: 15 30 50