Dungeon Warfare
Please Fix the Level Ruining Glitch
Enemies, despite the portal being behind walls, somehow get into it losing an HP without actually walking there. NOT MY FAULT! The enemies did not get past my defenses. Enemies, and/or their gibs, shouldn't fly through walls causing me to lose portal HP.
Enemy gets killed by minecart on the other side of a solid wall? Ding! Lost HP. (sometimes multiple) Blown up by exploding enemies on the other side of a solid wall? Ding! Lost HP. (sometimes multiple) Get thrown into a solid wall surrounding the portal over Lava? Ding! Lost HP. (just to be clear, the outside of the portal wall, not the side facing the portal)

The 1HP portal rune is a favorite of mine because it poses no extra challenge, but gives more XP, if I play well. Dungeon Warfare is definitely one of the THE BEST tower defense (or whatever you want to call it) games I've played, but this glitch ruins my runs, and therefore wastes my time since I have to start over.
Last edited by DaetherX; Feb 12 @ 8:04pm
< >
Showing 1-11 of 11 comments
Sylxeria Feb 12 @ 7:04pm 
I've never actually noticed this happening myself, but that sounds like something that should be fixed once they get the chance to do so. :<
Listege  [developer] Feb 13 @ 7:38pm 
Hello DaetherX.
We know units walk through wall rarely because of physics glitch, but it looks like it happens too often for you.
Can I know what OS you are using?
DaetherX Feb 13 @ 9:13pm 
Windows 7
Happens all the time to me - look at this wall layout, it resolves the issue, and bombers; my game is currently in progress in the background as I type this.

edit: the core of the issue is unit stacking in a spot where they compress past the collision detection boundary of the wall; ;just lay them in non-tip-to-tip sequence (wall long side to wall long side only) to form non-diagnonal connections.

Last edited by SimplyNoobin; Feb 21 @ 11:12am
A few other tips to maximize your gameplay (not play style) for max score -
1: use the right click on object feature to slow time during all gameplay; never play at 1x or 2x or 4x (unless you choose to for some reason) this resolves the kill calulator lag issue
2: use the pause feature whenever you lay new tiles or upgrade existing ones, or destroy tiles.
3: use the mouse button to click on your consumable and placing it during slow mo play; not key press; it will not only lay it in slow mo, it will continue to regenerate for next use, and your slow mo, right click, is unaffected.
Hey Listege - just fyi; you put another one out, I'm in for $20; that's worth supporting you. I'm on Win10 BTW with the wall issue. 100% reproducible any time you setup a slow chokepoint.
DaetherX Feb 21 @ 6:00pm 
There's a pause feature?!?
As far as I was aware, the only time that time stops after your initial setup phase is when a baricade is destroyed it pauses to let you place a new one. Have I been blindly missing a feature that I really wanted this whole time?
Listege  [developer] Feb 21 @ 11:20pm 
SimplyNoobin // Thank you for the information. If you don't mind, would you give me the screenshot of recommended trap setup for reproduce the problem? It's hard to fix because it's mainly the problem of Physics engine but I'll try to find out the way to fix it.

DaetherX // You can pause the game by pressing Tab key(by default, it's resignable to other key on option menu)
ive been holding open the "upgrade tower" radial to slow down time, didnt realize there was a pause button, ty.
ADV Feb 26 @ 12:42pm 
It's not just when choking. Wizards spawn golems behind walls, when squished against a wall by overcrowding.
also explosions and springs can cause them to go thru the wall as well. I tend to avoid walls if I can help it.
< >
Showing 1-11 of 11 comments
Per page: 15 30 50