Italian Sugar Daddy 14. sep, 2013 @ 11:31am
Framerate LAG! **Tripwire fix this**
I cant play RS storm because of this framerate lag.. i have tried every possible troubleshooting option... and for my pc I have an i7 4770K & GTX 770 4GB so my pc isnt the issue. ITS THE GAME! i want this fixed, its one of my favorite games on steam and i cant play it at ALL. Please help....
Viser 1-5 av 5 kommentarer
< >
MKVLI 14. sep, 2013 @ 1:44pm 
You sure it's fps lag and not ping lag? I have a ping over 200 on most servers & get a lot of stutter/lag. When the connection is good then the game runs good even maxed out with hardware weaker than yours.
Italian Sugar Daddy 14. sep, 2013 @ 5:20pm 
Opprinnelig skrevet av kenny:
You sure it's fps lag and not ping lag? I have a ping over 200 on most servers & get a lot of stutter/lag. When the connection is good then the game runs good even maxed out with hardware weaker than yours.


No. my ping stays anywhere from 70-100 ping. never goes higher
PropaneAccessories 15. sep, 2013 @ 4:12pm 
im having the exact same problem to where you cant even play it, ill have low ping and it will jitter forward, i have an amd radion hd 6700 so ik its not the issue either.. i need help ._.
xcharliegx 15. sep, 2013 @ 4:57pm 
I don't know what to tell you, OP. My laptop uses a 2.2GHz i7 and has a Geforce GT 750M graphics card, and I can run RS and RO2 on ultra with slightly tuned down AA just fine.
Danielkaas94 30. mar @ 5:16am 
I have the same exact problem, there must be something in the game, that just eat my FPS, and that a shame, because damn this game is good.

And no, my computer is not a freaking toaster
Viser 1-5 av 5 kommentarer
< >
Per side: 15 30 50
Dato lagt ut: 14. sep, 2013 @ 11:31am
Innlegg: 5