Deafturtle the Throw Spirit Dec 14, 2012 @ 9:34am
Game freezes at the main menu
SOLUTION FOUND: Found the problem. Fiddled around in the settings, and it seems like the Hardware Physx option was causing the problem. Turned it off and everything's gone nicely since.

Just installed RO and have encountered a few problems.

Basically, if I enter any menu (server list, settings, etc) the screen will freeze after aprox 5-10 seconds of activity.

I've yet to get into any server as the game freezes before I'm able to.

Crashes also happen on the main menu after Alt Tab

Specs are:

i5-3570K
AMD Radeon 7800
8 GB RAM

EDIT:I've tried:

Verifying Cache
Turning off steam ingame overlay
Deleting config file
Reinstalling
Restart Steam
Updated all Drivers
Restart PC


EDIT: If I'm fast enough I'm able to select Axis Campain and then difficutly; game then closes with no error prompt.

Last edited by Deafturtle the Throw Spirit; Dec 28, 2012 @ 5:03pm
Showing 1-13 of 13 comments
< >
coolnames Dec 14, 2012 @ 1:22pm 
brutal :(

Maybe try the official forums for TWI?
Deafturtle the Throw Spirit Dec 14, 2012 @ 3:44pm 
bump
Rollo Dec 14, 2012 @ 4:28pm 
Ask on the Offical RO2 forums you will get more help there.
K@n@y Dec 15, 2012 @ 2:17am 
Hello, if you use a realtek sound on your motherboard try to update to the latest drivers avalaible it might helps a bit in some cases.
[GB] I.Rapid Dec 15, 2012 @ 3:03am 
I've never had any problems with RO2. I've had various crashes, but that's nothing any different from any other game I own. Your specs are most likely the problem.
Deafturtle the Throw Spirit Dec 16, 2012 @ 6:15pm 
Found the problem. Fiddled around in the settings, and it seems like the Hardware Physx option was causing the problem. Turned it off and everything's gone nicely since.
Last edited by Deafturtle the Throw Spirit; Dec 28, 2012 @ 5:03pm
Valenson Dec 22, 2012 @ 10:11am 
I have the same problem :(
Valenson Dec 22, 2012 @ 10:14am 
How to turn off Hardware physx?
K@n@y Dec 22, 2012 @ 10:23am 
Disable it in the game video otpions settings then go to "C:\Users\User\Documents\My Games\RedOrchestra2\ROGame\Config\" open the file ROEngine.ini in a text editor and search for this entrie to verify to is completly disabled :

bDisablePhysXHardwareSupport=

There is 3 lines like this on this file, that must be set to =True, like this :
bDisablePhysXHardwareSupport=True
Valenson Dec 22, 2012 @ 12:48pm 
I can't go in the game to disable it because in 5 seconds at main menu the game freezes.
K@n@y Dec 22, 2012 @ 1:34pm 
Just modify the entries in the file i listed then, it will do the same ^^
make sure to check the 3 entries named "bDisablePhysXHardwareSupport="
(WH)WidowMaker(UK) Jun 2, 2013 @ 3:04pm 
I have had this issue before with RO2 it fixed it self but as i was a tester for rising strom i was told it was a fire wall issue by one of the game programers. fire wall issue could well be a windows update that has altered the games permissions also. I had this with gtaiv where game would run with no error then it would stop at a black screen this was solved by altering the permission for gtaivbroswer.exe. back to RO2 in your steam game folder have a browse for a file called bineries then open a folder called win32 and run the game updater in there called RO2Redist.exe then run the pbsvc_hos.exe follow the on screen instruction then restart pc when all done. i hope this helps.

this is also a fix for the main menu freeze run pb update for the game and not the one found in game folder.
download the update software from here. http://www.evenbalance.com/index.php?page=pbsetup.php

TIP: put the pbsetup.exe and files in a new folder before you run it. the update software makes a few files so it remembers what games and files have been added, other wise if you run this on desktop you will have a few files placed there.
Last edited by (WH)WidowMaker(UK); Jun 2, 2013 @ 4:05pm
xxxspotxxx Aug 10, 2014 @ 8:02pm 
I have same problem, but I can't solve it. Already tried to disable Hardware PhysX and update PB.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Dec 14, 2012 @ 9:34am
Posts: 13